{"answers":{"affected":"4 open source packages ship an affected version, including prestashop/ps_checkout. It affects 1 product.","exploited":"There is no known exploitation of CVE-2025-61923 in the wild and no public exploit code.","fix":"Upgrade prestashop/ps_checkout to a fixed version for your release line: 4.4.1 or 5.0.5.","what":"CVE-2025-61923 is a medium-severity path traversal vulnerability in PrestaShopCorp ps_checkout, published on 16 Oct 2025. An attacker needs administrator access to exploit it, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2025-61923 and fix it if it is affected.\n\nWhat it is: CVE-2025-61923 is a medium-severity path traversal vulnerability in PrestaShopCorp ps_checkout, published on 16 Oct 2025. An attacker needs administrator access to exploit it, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2025-61923 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- prestashop/ps_checkout (Packagist): affected all versions; fixed in 4.4.1\n- prestashop/ps_checkout (Packagist): affected all versions; fixed in 4.4.1\n- prestashop/ps_checkout (Packagist): affected from 5.0.0; fixed in 5.0.5\n- prestashop/ps_checkout (Packagist): affected from 5.0.0; fixed in 5.0.5\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-61923/ (Markdown: https://insights.sbomify.com/CVE-2025-61923/index.md)","id":"CVE-2025-61923","markdown":"https://insights.sbomify.com/CVE-2025-61923/index.md","name":"CVE-2025-61923","record":{"aliases":["GHSA-fpxp-pfqm-x54w"],"analysis":{"component_type":"cms_plugin","fix_type":"upgrade","impacts":["data_read"],"network_reachable":"yes","non_default_config":false,"product_category":"PrestaShop payment module","requires_auth":"high_privilege","summary":"Attackers can exploit missing input validation in the PrestaShop Checkout backoffice to perform directory traversal and disclose arbitrary files.","user_interaction":"not_required","vuln_class":"path_traversal"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"prestashop_checkout","vendor":"prestashop"}],"cvss":{"score":4.1,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:C/C:L/I:N/A:N","version":"3.1"},"cwes":[{"id":"CWE-22","name":"Improper Limitation of a Pathname to a Restricted Directory"}],"description":"PrestaShop Checkout is the PrestaShop official payment module in partnership with PayPal. In versions prior to 4.4.1 and 5.0.5, the backoffice is missing validation on input resulting in a directory traversal and arbitrary file disclosure. The vulnerability is fixed in versions 4.4.1 and 5.0.5. No known workarounds exist.","ecosystems":["Packagist"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"PrestaShop Checkout Backoffice directory traversal allows arbitrary file disclosure","id":"CVE-2025-61923","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":null,"products":[],"type":"path_traversal","year":"2025"},"n_packages":4,"n_references":1,"next":{"headline":"PrestaShop Checkout Target PayPal merchant account hijacking from backoffice","id":"CVE-2025-61924"},"packages":[{"ecosystem":"Packagist","fixed":["4.4.1"],"introduced":["0"],"last_affected":[],"package":"prestashop/ps_checkout","purl":null,"source":"GHSA-fpxp-pfqm-x54w"},{"ecosystem":"Packagist","fixed":["4.4.1"],"introduced":["0"],"last_affected":[],"package":"prestashop/ps_checkout","purl":"pkg:composer/prestashop/ps_checkout","source":"GHSA-fpxp-pfqm-x54w"},{"ecosystem":"Packagist","fixed":["5.0.5"],"introduced":["5.0.0"],"last_affected":[],"package":"prestashop/ps_checkout","purl":null,"source":"GHSA-fpxp-pfqm-x54w"},{"ecosystem":"Packagist","fixed":["5.0.5"],"introduced":["5.0.0"],"last_affected":[],"package":"prestashop/ps_checkout","purl":"pkg:composer/prestashop/ps_checkout","source":"GHSA-fpxp-pfqm-x54w"}],"prev":{"headline":"PrestaShop Checkout allows customer account takeover via email","id":"CVE-2025-61922"},"products":["ps_checkout"],"published":"2025-10-16","related":[{"cvss_score":9.1,"headline":"PrestaShop Checkout allows customer account takeover via email","id":"CVE-2025-61922","kev_date_added":null,"published":"2025-10-16"},{"cvss_score":3.8,"headline":"PrestaShop Checkout Target PayPal merchant account hijacking from backoffice","id":"CVE-2025-61924","kev_date_added":null,"published":"2025-10-16"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-10-16","vendors":["PrestaShopCorp"]},"summary":"Attackers can exploit missing input validation in the PrestaShop Checkout backoffice to perform directory traversal and disclose arbitrary files.","url":"https://insights.sbomify.com/CVE-2025-61923/"}