{"answers":{"affected":"4 open source packages ship an affected version, including prestashop/ps_checkout. It affects 1 product.","exploited":"There is no known exploitation of CVE-2025-61924 in the wild and no public exploit code.","fix":"Upgrade prestashop/ps_checkout to a fixed version for your release line: 4.4.1 or 5.0.5.","what":"CVE-2025-61924 is a low-severity vulnerability in PrestaShopCorp ps_checkout, published on 16 Oct 2025. An attacker needs administrator access to exploit it, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2025-61924 and fix it if it is affected.\n\nWhat it is: CVE-2025-61924 is a low-severity vulnerability in PrestaShopCorp ps_checkout, published on 16 Oct 2025. An attacker needs administrator access to exploit it, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2025-61924 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- prestashop/ps_checkout (Packagist): affected all versions; fixed in 4.4.1\n- prestashop/ps_checkout (Packagist): affected all versions; fixed in 4.4.1\n- prestashop/ps_checkout (Packagist): affected from 5.0.0; fixed in 5.0.5\n- prestashop/ps_checkout (Packagist): affected from 5.0.0; fixed in 5.0.5\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-61924/ (Markdown: https://insights.sbomify.com/CVE-2025-61924/index.md)","id":"CVE-2025-61924","markdown":"https://insights.sbomify.com/CVE-2025-61924/index.md","name":"CVE-2025-61924","record":{"aliases":["GHSA-wvpg-4wrh-5889"],"analysis":{"component_type":"cms_plugin","fix_type":"upgrade","impacts":["account_takeover"],"network_reachable":"yes","non_default_config":false,"product_category":"PrestaShop payment module","requires_auth":"high_privilege","summary":"An attacker with backoffice access can hijack the target PayPal merchant account due to flawed logic in the PrestaShop Checkout module.","user_interaction":"not_required","vuln_class":"business_logic"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"prestashop_checkout","vendor":"prestashop"}],"cvss":{"score":3.8,"severity":"low","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:L/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-184","name":"Incomplete List of Disallowed Inputs"}],"description":"PrestaShop Checkout is the PrestaShop official payment module in partnership with PayPal. In versions prior to 4.4.1 and 5.0.5, the Target PayPal merchant account hijacking from backoffice due to wrong usage of the PHP array_search(). The vulnerability is fixed in versions 4.4.1 and 5.0.5. No known workarounds exist.","ecosystems":["Packagist"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"PrestaShop Checkout Target PayPal merchant account hijacking from backoffice","id":"CVE-2025-61924","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":null,"products":[],"type":"business_logic","year":"2025"},"n_packages":4,"n_references":1,"next":{"headline":"Astro's `X-Forwarded-Host` is reflected with no validation","id":"CVE-2025-61925"},"packages":[{"ecosystem":"Packagist","fixed":["4.4.1"],"introduced":["0"],"last_affected":[],"package":"prestashop/ps_checkout","purl":null,"source":"GHSA-wvpg-4wrh-5889"},{"ecosystem":"Packagist","fixed":["4.4.1"],"introduced":["0"],"last_affected":[],"package":"prestashop/ps_checkout","purl":"pkg:composer/prestashop/ps_checkout","source":"GHSA-wvpg-4wrh-5889"},{"ecosystem":"Packagist","fixed":["5.0.5"],"introduced":["5.0.0"],"last_affected":[],"package":"prestashop/ps_checkout","purl":null,"source":"GHSA-wvpg-4wrh-5889"},{"ecosystem":"Packagist","fixed":["5.0.5"],"introduced":["5.0.0"],"last_affected":[],"package":"prestashop/ps_checkout","purl":"pkg:composer/prestashop/ps_checkout","source":"GHSA-wvpg-4wrh-5889"}],"prev":{"headline":"PrestaShop Checkout Backoffice directory traversal allows arbitrary file disclosure","id":"CVE-2025-61923"},"products":["ps_checkout"],"published":"2025-10-16","related":[{"cvss_score":9.1,"headline":"PrestaShop Checkout allows customer account takeover via email","id":"CVE-2025-61922","kev_date_added":null,"published":"2025-10-16"},{"cvss_score":4.1,"headline":"PrestaShop Checkout Backoffice directory traversal allows arbitrary file disclosure","id":"CVE-2025-61923","kev_date_added":null,"published":"2025-10-16"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-10-16","vendors":["PrestaShopCorp"]},"summary":"An attacker with backoffice access can hijack the target PayPal merchant account due to flawed logic in the PrestaShop Checkout module.","url":"https://insights.sbomify.com/CVE-2025-61924/"}