# CVE-2025-61924: PrestaShop Checkout Target PayPal merchant account hijacking from backoffice

> An attacker with backoffice access can hijack the target PayPal merchant account due to flawed logic in the PrestaShop Checkout module.

- **Severity:** Low 3.8 (`CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 16 Oct 2025
- **Updated:** 16 Oct 2025
- **Also known as:** GHSA-wvpg-4wrh-5889

## What is CVE-2025-61924?

CVE-2025-61924 is a low-severity vulnerability in PrestaShopCorp ps_checkout, published on 16 Oct 2025. An attacker needs administrator access to exploit it, with no action from the victim.

### Official description

PrestaShop Checkout is the PrestaShop official payment module in partnership with PayPal. In versions prior to 4.4.1 and 5.0.5, the Target PayPal merchant account hijacking from backoffice due to wrong usage of the PHP array_search(). The vulnerability is fixed in versions 4.4.1 and 5.0.5. No known workarounds exist.

Weakness: CWE-184 (Incomplete List of Disallowed Inputs)

## Which versions are affected by CVE-2025-61924?

4 open source packages ship an affected version, including prestashop/ps_checkout. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `prestashop/ps_checkout` | Packagist | All versions | 4.4.1 |
| `prestashop/ps_checkout` | Packagist | All versions | 4.4.1 |
| `prestashop/ps_checkout` | Packagist | From 5.0.0 | 5.0.5 |
| `prestashop/ps_checkout` | Packagist | From 5.0.0 | 5.0.5 |

Products: Prestashop Prestashop Checkout.

## How do I fix CVE-2025-61924?

Upgrade prestashop/ps_checkout to a fixed version for your release line: 4.4.1 or 5.0.5.

## Is CVE-2025-61924 being exploited?

There is no known exploitation of CVE-2025-61924 in the wild and no public exploit code.

## Other vulnerabilities in PrestaShopCorp ps_checkout

- [CVE-2025-61922](https://insights.sbomify.com/CVE-2025-61922/): PrestaShop Checkout allows customer account takeover via email (critical 9.1)
- [CVE-2025-61923](https://insights.sbomify.com/CVE-2025-61923/): PrestaShop Checkout Backoffice directory traversal allows arbitrary file disclosure (medium 4.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-61924 and fix it if it is affected.

What it is: CVE-2025-61924 is a low-severity vulnerability in PrestaShopCorp ps_checkout, published on 16 Oct 2025. An attacker needs administrator access to exploit it, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-61924 in the wild and no public exploit code.

Affected packages and fixed versions:
- prestashop/ps_checkout (Packagist): affected all versions; fixed in 4.4.1
- prestashop/ps_checkout (Packagist): affected all versions; fixed in 4.4.1
- prestashop/ps_checkout (Packagist): affected from 5.0.0; fixed in 5.0.5
- prestashop/ps_checkout (Packagist): affected from 5.0.0; fixed in 5.0.5

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-61924/ (Markdown: https://insights.sbomify.com/CVE-2025-61924/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-61924
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-61924
- OSV: https://osv.dev/vulnerability/CVE-2025-61924

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-61924/
Summaries are generated and may contain mistakes; the official description above is the record.
