CVE-2025-6195 Direct Request ('Forced Browsing') in GitLab
Authenticated users can view security report information via forced browsing under specific configuration conditions.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2025-6195?
CVE-2025-6195 is a medium-severity missing authorization vulnerability in Gitlab Gitlab, published on 26 Nov 2025. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
GitLab has remediated an issue in GitLab EE affecting all versions from 13.7 before 18.4.5, 18.5 before 18.5.3, and 18.6 before 18.6.1 that could have allowed an authenticated user to view information from security reports under certain configuration conditions.
Weakness: CWE-425
Which versions are affected by CVE-2025-6195?
1 open source package ship an affected version, including gitlab. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
gitlab Bitnami | From 13.7.0 | 18.4.5, 18.5.3, 18.6.1 |
Products include Gitlab Gitlab.
How do I fix CVE-2025-6195?
Upgrade gitlab to a fixed version for your release line: 18.4.5, 18.5.3 or 18.6.1.
Upgrade, and check permissions on every request on the server, not only in the interface. More about Missing authorization.
Is CVE-2025-6195 being exploited?
There is no known exploitation of CVE-2025-6195 in the wild and no public exploit code.
Other vulnerabilities in Gitlab Gitlab
- CVE-2026-97229 GitLab Community Edition and Enterprise Edition Integer Overflow or Wraparound
- CVE-2026-85706 GitLab Community Edition and Enterprise Edition Path Traversal
- CVE-2023-7028 GitLab Community and Enterprise Editions Improper Access Control
- CVE-2021-22205 GitLab Community and Enterprise Editions Remote Code Execution
- CVE-2021-39935 GitLab Community and Enterprise Editions Server-Side Request Forgery (SSRF)
Sources
Also known as BIT-gitlab-2025-6195, GHSA-2cpf-j432-984q.