{"answers":{"affected":"","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-61984 exists.","fix":"Upgrade to a fixed version.","what":"CVE-2025-61984 is a low-severity command injection vulnerability in OpenBSD OpenSSH, published on 6 Oct 2025. It can only be exploited from the same machine or local network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2025-61984 and fix it if it is affected.\n\nWhat it is: CVE-2025-61984 is a low-severity command injection vulnerability in OpenBSD OpenSSH, published on 6 Oct 2025. It can only be exploited from the same machine or local network, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-61984 exists.\n\nAffected product: OpenBSD OpenSSH. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-61984/ (Markdown: https://insights.sbomify.com/CVE-2025-61984/index.md)","id":"CVE-2025-61984","markdown":"https://insights.sbomify.com/CVE-2025-61984/index.md","name":"CVE-2025-61984","record":{"aliases":["ALPINE-CVE-2025-61984","AZL-68231","BELL-CVE-2025-61984","DEBIAN-CVE-2025-61984","ECHO-8420-5303-4f71","GHSA-hh67-847q-q3h9","JLSEC-2025-7","SUSE-SU-2025:4097-1","UBUNTU-CVE-2025-61984"],"analysis":{"component_type":"server_software","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"adjacent_or_local","non_default_config":true,"product_category":"OpenSSH client","requires_auth":"low_privilege","summary":"OpenSSH allows control characters in untrusted usernames, enabling code execution when ProxyCommand is used.","user_interaction":"not_required","vuln_class":"command_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[],"cvss":{"score":3.6,"severity":"low","source":"cna","vector":"CVSS:3.1/AV:L/AC:H/PR:L/UI:N/S:U/C:L/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-159","name":"Improper Handling of Invalid Use of Special Elements"}],"description":"ssh in OpenSSH before 10.1 allows control characters in usernames that originate from certain possibly untrusted sources, potentially leading to code execution when a ProxyCommand is used. The untrusted sources are the command line and %-sequence expansion of a configuration file. (A configuration file that provides a complete literal username is not categorized as an untrusted source.)","ecosystems":["SUSE:Linux Enterprise Server 12 SP5-LTSS","SUSE:Linux Enterprise Server LTSS Extended Security 12 SP5"],"exploits":{"exploitdb":0,"first_seen":"2025-10-07","github_poc":2,"max_poc_stars":7,"metasploit":0,"nuclei":0,"refs":[{"date":"2025-10-07T03:17:03Z","kind":"github_poc","ref":"https://github.com/dgl/cve-2025-61984-poc","stars":7,"title":"PoC for OpenSSH ProxyCommand CVE-2025-61984"},{"date":"2025-10-24T01:31:48Z","kind":"github_poc","ref":"https://github.com/flyskyfire/cve-2025-61984-poc","stars":0,"title":"PoC for CVE-2025-61984"}],"tier":"weaponised"},"has_fix":true,"headline":"Command injection in OpenSSH","id":"CVE-2025-61984","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"command_injection","year":"2025"},"n_packages":4,"n_references":3,"next":{"headline":"Command injection in OpenSSH","id":"CVE-2025-61985"},"packages":[{"ecosystem":"SUSE:Linux Enterprise Server 12 SP5-LTSS","fixed":["7.2p2-81.34.1"],"introduced":["0"],"last_affected":[],"package":"openssh","purl":"pkg:rpm/suse/openssh\u0026distro=SUSE%20Linux%20Enterprise%20Server%2012%20SP5-LTSS","source":"SUSE-SU-2025:4097-1"},{"ecosystem":"SUSE:Linux Enterprise Server 12 SP5-LTSS","fixed":["7.2p2-81.34.1"],"introduced":["0"],"last_affected":[],"package":"openssh-askpass-gnome","purl":"pkg:rpm/suse/openssh-askpass-gnome\u0026distro=SUSE%20Linux%20Enterprise%20Server%2012%20SP5-LTSS","source":"SUSE-SU-2025:4097-1"},{"ecosystem":"SUSE:Linux Enterprise Server LTSS Extended Security 12 SP5","fixed":["7.2p2-81.34.1"],"introduced":["0"],"last_affected":[],"package":"openssh","purl":"pkg:rpm/suse/openssh\u0026distro=SUSE%20Linux%20Enterprise%20Server%20LTSS%20Extended%20Security%2012%20SP5","source":"SUSE-SU-2025:4097-1"},{"ecosystem":"SUSE:Linux Enterprise Server LTSS Extended Security 12 SP5","fixed":["7.2p2-81.34.1"],"introduced":["0"],"last_affected":[],"package":"openssh-askpass-gnome","purl":"pkg:rpm/suse/openssh-askpass-gnome\u0026distro=SUSE%20Linux%20Enterprise%20Server%20LTSS%20Extended%20Security%2012%20SP5","source":"SUSE-SU-2025:4097-1"}],"prev":{"headline":"Heap-based Buffer Overflow Vulnerability in TP-Link Archer AX53","id":"CVE-2025-61983"},"products":["OpenSSH"],"published":"2025-10-06","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"SUSE","prefix":"SUSE"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"},{"class":"open","licence":"CC0","name":"PoC-in-GitHub"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"total"},"state":"PUBLISHED","updated":"2026-10-15","vendors":["OpenBSD"]},"summary":"OpenSSH allows control characters in untrusted usernames, enabling code execution when ProxyCommand is used.","url":"https://insights.sbomify.com/CVE-2025-61984/"}