CVE-2025-6203 Vault unauthenticated denial of service through complex json payload

High 7.5 Published Updated

An unauthenticated attacker can cause Vault to become unresponsive by submitting a complex JSON payload that exhausts memory and CPU resources.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2025-6203?

CVE-2025-6203 is a high-severity denial of service vulnerability in Hashicorp Vault, published on 28 Aug 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

A malicious user may submit a specially-crafted complex payload that otherwise meets the default request size limit which results in excessive memory and CPU consumption of Vault. This may lead to a timeout in Vault’s auditing subroutine, potentially resulting in the Vault server to become unresponsive. This vulnerability, CVE-2025-6203, is fixed in Vault Community Edition 1.20.3 and Vault Enterprise 1.20.3, 1.19.9, 1.18.14, and 1.16.25.

Weakness: CWE-770

Which versions are affected by CVE-2025-6203?

4 open source packages ship an affected version, including github.com/hashicorp/vault and vault. It affects 1 product.

PackageAffectedFixed in
github.com/hashicorp/vault GoAll versions1.20.3
github.com/hashicorp/vault GoAll versions1.20.3
github.com/hashicorp/vault GoAll versions1.20.3
vault BitnamiFrom 1.15.01.20.3
Linux distribution packages (1)
openbao openSUSE:TumbleweedAll versions2.4.1-1.1

Products include Hashicorp Vault.

How do I fix CVE-2025-6203?

Upgrade github.com/hashicorp/vault to 1.20.3 or later.

Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.

Is CVE-2025-6203 being exploited?

There is no known exploitation of CVE-2025-6203 in the wild and no public exploit code.

All Hashicorp Vault vulnerabilities

Sources

Also known as BIT-vault-2025-6203, GHSA-8f82-53h8-2p34, GO-2025-3924, MINI-6j2q-v8gv-c9j2, openSUSE-SU-2025:15579-1.

Is CVE-2025-6203 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free