# CVE-2025-6203: Vault unauthenticated denial of service through complex json payload

> An unauthenticated attacker can cause Vault to become unresponsive by submitting a complex JSON payload that exhausts memory and CPU resources.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 28 Aug 2025
- **Updated:** 23 Oct 2025
- **Also known as:** BIT-vault-2025-6203, GHSA-8f82-53h8-2p34, GO-2025-3924, MINI-6j2q-v8gv-c9j2, openSUSE-SU-2025:15579-1

## What is CVE-2025-6203?

CVE-2025-6203 is a high-severity denial of service vulnerability in Hashicorp Vault, published on 28 Aug 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

A malicious user may submit a specially-crafted complex payload that otherwise meets the default request size limit which results in excessive memory and CPU consumption of Vault. This may lead to a timeout in Vault’s auditing subroutine, potentially resulting in the Vault server to become unresponsive. This vulnerability, CVE-2025-6203, is fixed in Vault Community Edition 1.20.3 and Vault Enterprise 1.20.3, 1.19.9, 1.18.14, and 1.16.25.

Weakness: CWE-770 (Allocation of Resources Without Limits or Throttling)

## Which versions are affected by CVE-2025-6203?

4 open source packages ship an affected version, including github.com/hashicorp/vault and vault. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/hashicorp/vault` | Go | All versions | 1.20.3 |
| `github.com/hashicorp/vault` | Go | All versions | 1.20.3 |
| `github.com/hashicorp/vault` | Go | All versions | 1.20.3 |
| `vault` | Bitnami | From 1.15.0 | 1.20.3 |
| `openbao` | openSUSE:Tumbleweed | All versions | 2.4.1-1.1 |

Products: Hashicorp Vault.

## How do I fix CVE-2025-6203?

Upgrade github.com/hashicorp/vault to 1.20.3 or later.

## Is CVE-2025-6203 being exploited?

There is no known exploitation of CVE-2025-6203 in the wild and no public exploit code.

## Other vulnerabilities in Hashicorp Vault

- [CVE-2020-35192](https://insights.sbomify.com/CVE-2020-35192/): Hardcoded credentials in n/a (critical 9.8)
- [CVE-2020-12757](https://insights.sbomify.com/CVE-2020-12757/): Improper Input Validation in HashiCorp Vault (critical 9.8)
- [CVE-2025-6000](https://insights.sbomify.com/CVE-2025-6000/): Arbitrary Remote Code Execution via Plugin Catalog Abuse (critical 9.1)
- [CVE-2022-40186](https://insights.sbomify.com/CVE-2022-40186/): HashiCorp Vault vulnerable to incorrect metadata access (critical 9.1)
- [CVE-2022-36129](https://insights.sbomify.com/CVE-2022-36129/): Missing authorization in n/a (critical 9.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-6203 and fix it if it is affected.

What it is: CVE-2025-6203 is a high-severity denial of service vulnerability in Hashicorp Vault, published on 28 Aug 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-6203 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/hashicorp/vault (Go): affected all versions; fixed in 1.20.3
- github.com/hashicorp/vault (Go): affected all versions; fixed in 1.20.3
- github.com/hashicorp/vault (Go): affected all versions; fixed in 1.20.3
- vault (Bitnami): affected from 1.15.0; fixed in 1.20.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-6203/ (Markdown: https://insights.sbomify.com/CVE-2025-6203/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-6203
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-6203
- OSV: https://osv.dev/vulnerability/CVE-2025-6203

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-6203/
Summaries are generated and may contain mistakes; the official description above is the record.
