{"answers":{"affected":"3 open source packages ship an affected version, including llama-index-core.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-6208 exists.","fix":"Upgrade llama-index-core to 0.12.41 or later.","what":"CVE-2025-6208 is a medium-severity denial of service vulnerability in run-llama/llama_index, published on 2 Feb 2026. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2025-6208 and fix it if it is affected.\n\nWhat it is: CVE-2025-6208 is a medium-severity denial of service vulnerability in run-llama/llama_index, published on 2 Feb 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-6208 exists.\n\nAffected packages and fixed versions:\n- llama-index-core (PyPI): affected all versions; fixed in 0.12.41\n- llama-index-core (PyPI): affected all versions; fixed in 0.12.41\n- llama-index-core (PyPI): affected all versions; fixed in 0.12.41\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-6208/ (Markdown: https://insights.sbomify.com/CVE-2025-6208/index.md)","id":"CVE-2025-6208","markdown":"https://insights.sbomify.com/CVE-2025-6208/index.md","name":"CVE-2025-6208","record":{"aliases":["GHSA-488g-hw5f-x29p","PYSEC-2026-1560"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"Python LLM library","requires_auth":"none","summary":"Attackers can cause memory exhaustion in llama_index by exploiting a flaw where file limits are applied after loading all files into memory.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"@huntr_ai","cpe":[],"cvss":{"score":5.3,"severity":"medium","source":"cna","vector":"CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L","version":"3.0"},"cwes":[{"id":"CWE-400","name":"Uncontrolled Resource Consumption"}],"description":"The `SimpleDirectoryReader` component in `llama_index.core` version 0.12.23 suffers from uncontrolled memory consumption due to a resource management flaw. The vulnerability arises because the user-specified file limit (`num_files_limit`) is applied after all files in a directory are loaded into memory. This can lead to memory exhaustion and degraded performance, particularly in environments with limited resources. The issue is resolved in version 0.12.41.","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"Uncontrolled Memory Consumption in run-llama/llama_index","id":"CVE-2025-6208","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"denial_of_service","year":"2025"},"n_packages":3,"n_references":2,"next":{"headline":"Arbitrary File Read through Path Traversal in run-llama/llama_index","id":"CVE-2025-6209"},"packages":[{"ecosystem":"PyPI","fixed":["0.12.41"],"introduced":["0"],"last_affected":[],"package":"llama-index-core","purl":null,"source":"GHSA-488g-hw5f-x29p"},{"ecosystem":"PyPI","fixed":["0.12.41"],"introduced":["0"],"last_affected":[],"package":"llama-index-core","purl":"pkg:pypi/llama-index-core","source":"GHSA-488g-hw5f-x29p"},{"ecosystem":"PyPI","fixed":["0.12.41"],"introduced":["0"],"last_affected":[],"package":"llama-index-core","purl":"pkg:pypi/llama-index-core","source":"PYSEC-2026-1560"}],"prev":{"headline":"WP Import Export Lite \u003c= 3.9.28 - Authenticated (Subscriber+) Arbitrary File Upload","id":"CVE-2025-6207"},"products":["run-llama/llama_index"],"published":"2026-02-02","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-02-02","vendors":["run-llama"]},"summary":"Attackers can cause memory exhaustion in llama_index by exploiting a flaw where file limits are applied after loading all files into memory.","url":"https://insights.sbomify.com/CVE-2025-6208/"}