# CVE-2025-6208: Uncontrolled Memory Consumption in run-llama/llama_index

> Attackers can cause memory exhaustion in llama_index by exploiting a flaw where file limits are applied after loading all files into memory.

- **Severity:** Medium 5.3 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 2 Feb 2026
- **Updated:** 2 Feb 2026
- **Also known as:** GHSA-488g-hw5f-x29p, PYSEC-2026-1560

## What is CVE-2025-6208?

CVE-2025-6208 is a medium-severity denial of service vulnerability in run-llama/llama_index, published on 2 Feb 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

The `SimpleDirectoryReader` component in `llama_index.core` version 0.12.23 suffers from uncontrolled memory consumption due to a resource management flaw. The vulnerability arises because the user-specified file limit (`num_files_limit`) is applied after all files in a directory are loaded into memory. This can lead to memory exhaustion and degraded performance, particularly in environments with limited resources. The issue is resolved in version 0.12.41.

Weakness: CWE-400 (Uncontrolled Resource Consumption)

## Which versions are affected by CVE-2025-6208?

3 open source packages ship an affected version, including llama-index-core.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `llama-index-core` | PyPI | All versions | 0.12.41 |
| `llama-index-core` | PyPI | All versions | 0.12.41 |
| `llama-index-core` | PyPI | All versions | 0.12.41 |

## How do I fix CVE-2025-6208?

Upgrade llama-index-core to 0.12.41 or later.

## Is CVE-2025-6208 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-6208 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-6208 and fix it if it is affected.

What it is: CVE-2025-6208 is a medium-severity denial of service vulnerability in run-llama/llama_index, published on 2 Feb 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-6208 exists.

Affected packages and fixed versions:
- llama-index-core (PyPI): affected all versions; fixed in 0.12.41
- llama-index-core (PyPI): affected all versions; fixed in 0.12.41
- llama-index-core (PyPI): affected all versions; fixed in 0.12.41

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-6208/ (Markdown: https://insights.sbomify.com/CVE-2025-6208/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-6208
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-6208
- OSV: https://osv.dev/vulnerability/CVE-2025-6208

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-6208/
Summaries are generated and may contain mistakes; the official description above is the record.
