CVE-2025-6209 Arbitrary File Read through Path Traversal in run-llama/llama_index
Attackers can read arbitrary server files via path traversal in the image encoding function of the llama_index library.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2025-6209?
CVE-2025-6209 is a high-severity path traversal vulnerability in run-llama/llama_index, published on 7 Jul 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
A path traversal vulnerability exists in run-llama/llama_index versions 0.12.27 through 0.12.40, specifically within the `encode_image` function in `generic_utils.py`. This vulnerability allows an attacker to manipulate the `image_path` input to read arbitrary files on the server, including sensitive system files. The issue arises due to improper validation or sanitization of the file path, enabling path traversal sequences to access files outside the intended directory. The vulnerability is fixed in version 0.12.41.
Weakness: CWE-29
Which versions are affected by CVE-2025-6209?
4 open source packages ship an affected version, including llama-index-core and llama-index. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
llama-index-core PyPI | From 0.11.23 | 0.12.41 |
llama-index-core PyPI | From 0.11.23 | 0.12.41 |
llama-index-core PyPI | From 0.11.23 | 0.12.41 |
llama-index PyPI | From 0.12.27 | 0.12.41 |
Products include Llamaindex Llamaindex.
How do I fix CVE-2025-6209?
Upgrade llama-index-core to 0.12.41 or later.
Upgrade, and resolve every user-supplied path against an allowed base folder before opening it. More about Path traversal.
Is CVE-2025-6209 being exploited?
It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-6209 exists.
Other vulnerabilities in run-llama/llama_index
Sources
Also known as GHSA-2rhq-96q8-4vjq, PYSEC-2025-65, PYSEC-2026-1558.