# CVE-2025-6209: Arbitrary File Read through Path Traversal in run-llama/llama_index

> Attackers can read arbitrary server files via path traversal in the image encoding function of the llama_index library.

- **Severity:** High 7.5 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 7 Jul 2025
- **Updated:** 7 Jul 2025
- **Also known as:** GHSA-2rhq-96q8-4vjq, PYSEC-2025-65, PYSEC-2026-1558

## What is CVE-2025-6209?

CVE-2025-6209 is a high-severity path traversal vulnerability in run-llama/llama_index, published on 7 Jul 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

A path traversal vulnerability exists in run-llama/llama_index versions 0.12.27 through 0.12.40, specifically within the `encode_image` function in `generic_utils.py`. This vulnerability allows an attacker to manipulate the `image_path` input to read arbitrary files on the server, including sensitive system files. The issue arises due to improper validation or sanitization of the file path, enabling path traversal sequences to access files outside the intended directory. The vulnerability is fixed in version 0.12.41.

Weakness: CWE-29 (Path Traversal: '\..\filename')

## Which versions are affected by CVE-2025-6209?

4 open source packages ship an affected version, including llama-index-core and llama-index. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `llama-index-core` | PyPI | From 0.11.23 | 0.12.41 |
| `llama-index-core` | PyPI | From 0.11.23 | 0.12.41 |
| `llama-index-core` | PyPI | From 0.11.23 | 0.12.41 |
| `llama-index` | PyPI | From 0.12.27 | 0.12.41 |

Products: Llamaindex Llamaindex.

## How do I fix CVE-2025-6209?

Upgrade llama-index-core to 0.12.41 or later.

## Is CVE-2025-6209 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-6209 exists.

## Other vulnerabilities in run-llama/llama_index

- [CVE-2024-12909](https://insights.sbomify.com/CVE-2024-12909/): SQL Injection to RCE in run-llama/llama_index (critical 10.0)
- [CVE-2025-1793](https://insights.sbomify.com/CVE-2025-1793/): SQL Injection in run-llama/llama_index (critical 9.8)
- [CVE-2025-1750](https://insights.sbomify.com/CVE-2025-1750/): SQL Injection in run-llama/llama_index (critical 9.8)
- [CVE-2024-11958](https://insights.sbomify.com/CVE-2024-11958/): SQL Injection in run-llama/llama_index (critical 9.8)
- [CVE-2024-3271](https://insights.sbomify.com/CVE-2024-3271/): Command Injection in run-llama/llama_index (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-6209 and fix it if it is affected.

What it is: CVE-2025-6209 is a high-severity path traversal vulnerability in run-llama/llama_index, published on 7 Jul 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-6209 exists.

Affected packages and fixed versions:
- llama-index-core (PyPI): affected from 0.11.23; fixed in 0.12.41
- llama-index-core (PyPI): affected from 0.11.23; fixed in 0.12.41
- llama-index-core (PyPI): affected from 0.11.23; fixed in 0.12.41
- llama-index (PyPI): affected from 0.12.27; fixed in 0.12.41

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-6209/ (Markdown: https://insights.sbomify.com/CVE-2025-6209/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-6209
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-6209
- OSV: https://osv.dev/vulnerability/CVE-2025-6209

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-6209/
Summaries are generated and may contain mistakes; the official description above is the record.
