# CVE-2025-6210: Hardlink-Based Path Traversal in run-llama/llama_index

> Attackers can bypass path restrictions to read sensitive system files via hardlinks in the ObsidianReader class of the llama_index library.

- **Severity:** Medium 6.2 (`CVSS:3.0/AV:L/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 7 Jul 2025
- **Updated:** 7 Jul 2025
- **Also known as:** GHSA-3j8r-jf9w-5cmh, PYSEC-2025-252, PYSEC-2026-1567

## What is CVE-2025-6210?

CVE-2025-6210 is a medium-severity path traversal vulnerability in run-llama/llama_index, published on 7 Jul 2025. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

A vulnerability in the ObsidianReader class of the run-llama/llama_index repository, specifically in version 0.12.27, allows for hardlink-based path traversal. This flaw permits attackers to bypass path restrictions and access sensitive system files, such as /etc/passwd, by exploiting hardlinks. The vulnerability arises from inadequate handling of hardlinks in the load_data() method, where the security checks fail to differentiate between real files and hardlinks. This issue is resolved in version 0.5.2.

Weakness: CWE-22 (Improper Limitation of a Pathname to a Restricted Directory)

## Which versions are affected by CVE-2025-6210?

4 open source packages ship an affected version, including llama-index-readers-obsidian and llama-index. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `llama-index-readers-obsidian` | PyPI | All versions | 0.5.2 |
| `llama-index-readers-obsidian` | PyPI | All versions | 0.5.2 |
| `llama-index-readers-obsidian` | PyPI | All versions | 0.5.2 |
| `llama-index` | PyPI | All versions | 0.5.2 |

Products: Llamaindex Llamaindex.

## How do I fix CVE-2025-6210?

Upgrade llama-index-readers-obsidian to 0.5.2 or later.

## Is CVE-2025-6210 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-6210 exists.

## Other vulnerabilities in run-llama/llama_index

- [CVE-2024-12909](https://insights.sbomify.com/CVE-2024-12909/): SQL Injection to RCE in run-llama/llama_index (critical 10.0)
- [CVE-2025-1793](https://insights.sbomify.com/CVE-2025-1793/): SQL Injection in run-llama/llama_index (critical 9.8)
- [CVE-2025-1750](https://insights.sbomify.com/CVE-2025-1750/): SQL Injection in run-llama/llama_index (critical 9.8)
- [CVE-2024-11958](https://insights.sbomify.com/CVE-2024-11958/): SQL Injection in run-llama/llama_index (critical 9.8)
- [CVE-2024-3271](https://insights.sbomify.com/CVE-2024-3271/): Command Injection in run-llama/llama_index (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-6210 and fix it if it is affected.

What it is: CVE-2025-6210 is a medium-severity path traversal vulnerability in run-llama/llama_index, published on 7 Jul 2025. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-6210 exists.

Affected packages and fixed versions:
- llama-index-readers-obsidian (PyPI): affected all versions; fixed in 0.5.2
- llama-index-readers-obsidian (PyPI): affected all versions; fixed in 0.5.2
- llama-index-readers-obsidian (PyPI): affected all versions; fixed in 0.5.2
- llama-index (PyPI): affected all versions; fixed in 0.5.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-6210/ (Markdown: https://insights.sbomify.com/CVE-2025-6210/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-6210
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-6210
- OSV: https://osv.dev/vulnerability/CVE-2025-6210

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-6210/
Summaries are generated and may contain mistakes; the official description above is the record.
