CVE-2025-6211 MD5 Hash Collision in run-llama/llama_index
Attackers can cause data loss and AI hallucinations in llama_index by exploiting MD5 hash collisions in document chunking.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2025-6211?
CVE-2025-6211 is a medium-severity vulnerability in run-llama/llama_index, published on 10 Jul 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
A vulnerability in the DocugamiReader class of the run-llama/llama_index repository, up to version 0.12.28, involves the use of MD5 hashing to generate IDs for document chunks. This approach leads to hash collisions when structurally distinct chunks contain identical text, resulting in one chunk overwriting another. This can cause loss of semantically or legally important document content, breakage of parent-child chunk hierarchies, and inaccurate or hallucinated responses in AI outputs. The issue is resolved in version 0.3.1.
Weakness: CWE-440
Which versions are affected by CVE-2025-6211?
6 open source packages ship an affected version, including llama-index and llama-index-readers-docugami. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
llama-index PyPI | All versions | 0.12.41 |
llama-index PyPI | All versions | 0.12.41 |
llama-index PyPI | All versions | 0.12.41 |
llama-index-readers-docugami PyPI | All versions | 0.3.1 |
llama-index-readers-docugami PyPI | All versions | 0.3.1 |
llama-index-readers-docugami PyPI | All versions | 0.3.1 |
Products include Llamaindex Llamaindex.
How do I fix CVE-2025-6211?
Upgrade llama-index to 0.12.41 or later.
Is CVE-2025-6211 being exploited?
It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-6211 exists.
Other vulnerabilities in run-llama/llama_index
Sources
Also known as GHSA-5hq9-5r78-2gjh, PYSEC-2026-1566, PYSEC-2026-2606.