# CVE-2025-62155: QuantumNous New API Has SSRF Bypass

> Attackers can bypass SSRF protections via 302 redirects to access internal networks in the New API LLM gateway.

- **Severity:** High 8.5 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 24 Nov 2025
- **Updated:** 25 Nov 2025
- **Also known as:** GHSA-9f46-w24h-69w4, GO-2025-4154

## What is CVE-2025-62155?

CVE-2025-62155 is a high-severity server-side request forgery vulnerability in QuantumNous new-api, published on 24 Nov 2025. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

New API is a large language mode (LLM) gateway and artificial intelligence (AI) asset management system. Prior to version 0.9.6, a recently patched SSRF vulnerability contains a bypass method that can bypass the existing security fix and still allow SSRF to occur.
Because the existing fix only applies security restrictions to the first URL request, a 302 redirect can bypass existing security measures and successfully access the intranet. This issue has been patched in version 0.9.6.

Weakness: CWE-918 (Server-Side Request Forgery)

## Which versions are affected by CVE-2025-62155?

3 open source packages ship an affected version, including github.com/QuantumNous/new-api.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/QuantumNous/new-api` | Go | All versions | None |
| `github.com/QuantumNous/new-api` | Go | All versions | 0.9.6 |
| `github.com/QuantumNous/new-api` | Go | All versions | 0.9.6 |

## How do I fix CVE-2025-62155?

Upgrade github.com/QuantumNous/new-api to 0.9.6 or later.

## Is CVE-2025-62155 being exploited?

There is no known exploitation of CVE-2025-62155 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-62155 and fix it if it is affected.

What it is: CVE-2025-62155 is a high-severity server-side request forgery vulnerability in QuantumNous new-api, published on 24 Nov 2025. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-62155 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/QuantumNous/new-api (Go): affected all versions; no fix listed
- github.com/QuantumNous/new-api (Go): affected all versions; fixed in 0.9.6
- github.com/QuantumNous/new-api (Go): affected all versions; fixed in 0.9.6

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-62155/ (Markdown: https://insights.sbomify.com/CVE-2025-62155/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-62155
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-62155
- OSV: https://osv.dev/vulnerability/CVE-2025-62155

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-62155/
Summaries are generated and may contain mistakes; the official description above is the record.
