# CVE-2025-62157: Argo Workflows exposes artifact repository credentials in workflow-controller logs

> Attackers with pod log access can steal artifact repository credentials exposed in plaintext logs, requiring an upgrade to secure the workflow engine.

- **Severity:** High 8.5 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:H/UI:N/VC:H/VI:H/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 14 Oct 2025
- **Updated:** 14 Oct 2025
- **Also known as:** BIT-argo-workflows-2025-62157, CLEANSTART-2026-NK14578, CLEANSTART-2026-WY17221, GHSA-c2hv-4pfj-mm2r, GO-2025-4024, MINI-2mj5-94cf-vx4p, MINI-7cg9-q64h-p623, MINI-7xwj-52w4-g24r, MINI-8v8f-hm66-h2wc, MINI-qjcw-r685-4j56, MINI-vr43-286c-325r

## What is CVE-2025-62157?

CVE-2025-62157 is a high-severity vulnerability in argoproj argo-workflows, published on 14 Oct 2025. An attacker needs administrator access to exploit it, with no action from the victim.

### Official description

Argo Workflows is an open source container-native workflow engine for orchestrating parallel jobs on Kubernetes. Argo Workflows versions prior to 3.6.12 and versions 3.7.0 through 3.7.2 expose artifact repository credentials in plaintext in workflow-controller pod logs. An attacker with permissions to read pod logs in a namespace running Argo Workflows can read the workflow-controller logs and obtain credentials to the artifact repository. Update to versions 3.6.12 or 3.7.3 to remediate the vulnerability. No known workarounds exist.

Weakness: CWE-522 (Insufficiently Protected Credentials)

## Which versions are affected by CVE-2025-62157?

8 open source packages ship an affected version, including github.com/argoproj/argo-workflows/v3, argo-workflows and github.com/argoproj/argo-workflows. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/argoproj/argo-workflows/v3` | Go | All versions | 3.6.12, 3.7.3 |
| `github.com/argoproj/argo-workflows/v3` | Go | All versions | 3.6.12 |
| `github.com/argoproj/argo-workflows/v3` | Go | All versions | 3.6.12 |
| `github.com/argoproj/argo-workflows/v3` | Go | From 3.7.0 | 3.7.3 |
| `github.com/argoproj/argo-workflows/v3` | Go | From 3.7.0 | 3.7.3 |
| `argo-workflows` | Bitnami | All versions | 3.6.12, 3.7.3 |
| `github.com/argoproj/argo-workflows` | Go | All versions | None |
| `github.com/argoproj/argo-workflows/v2` | Go | All versions | None |

Products: Argoproj Argo Workflows.

## How do I fix CVE-2025-62157?

Upgrade github.com/argoproj/argo-workflows/v3 to a fixed version for your release line: 3.6.12 or 3.7.3.

## Is CVE-2025-62157 being exploited?

There is no known exploitation of CVE-2025-62157 in the wild and no public exploit code.

## Other vulnerabilities in argoproj argo-workflows

- [CVE-2026-28229](https://insights.sbomify.com/CVE-2026-28229/): Argo Workflows has unauthorized access to Argo Workflows Template (critical 9.8)
- [CVE-2026-54526](https://insights.sbomify.com/CVE-2026-54526/): Argo Workflows: Incomplete fix for CVE-2026-31892: ArtifactGC.PodSpecPatch bypass of Strict/Secure templateReferencing (high 8.9)
- [CVE-2026-31892](https://insights.sbomify.com/CVE-2026-31892/): WorkflowTemplate Security Bypass via podSpecPatch in Strict/Secure Reference Mode (high 8.9)
- [CVE-2026-42295](https://insights.sbomify.com/CVE-2026-42295/): Argo Workflows: Exposure of artifact repository credentials (high 8.5)
- [CVE-2026-42297](https://insights.sbomify.com/CVE-2026-42297/): Argo Workflows Is Missing Authorization in Sync ConfigMap Provider (high 8.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-62157 and fix it if it is affected.

What it is: CVE-2025-62157 is a high-severity vulnerability in argoproj argo-workflows, published on 14 Oct 2025. An attacker needs administrator access to exploit it, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-62157 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/argoproj/argo-workflows/v3 (Go): affected all versions; fixed in 3.6.12, 3.7.3
- github.com/argoproj/argo-workflows/v3 (Go): affected all versions; fixed in 3.6.12
- github.com/argoproj/argo-workflows/v3 (Go): affected all versions; fixed in 3.6.12
- github.com/argoproj/argo-workflows/v3 (Go): affected from 3.7.0; fixed in 3.7.3
- github.com/argoproj/argo-workflows/v3 (Go): affected from 3.7.0; fixed in 3.7.3
- argo-workflows (Bitnami): affected all versions; fixed in 3.6.12, 3.7.3
- github.com/argoproj/argo-workflows (Go): affected all versions; no fix listed
- github.com/argoproj/argo-workflows/v2 (Go): affected all versions; no fix listed

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-62157/ (Markdown: https://insights.sbomify.com/CVE-2025-62157/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-62157
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-62157
- OSV: https://osv.dev/vulnerability/CVE-2025-62157

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-62157/
Summaries are generated and may contain mistakes; the official description above is the record.
