CVE-2025-62161 youki container escape via "masked path" abuse due to mount race conditions
High 7.3
Published
Updated
Check this codebase for CVE-2025-62161 and fix it if it is affected.
What it is: CVE-2025-62161 is a high-severity vulnerability in youki-dev youki, published on 5 Nov 2025.
Exploitation: There is no known exploitation of CVE-2025-62161 in the wild and no public exploit code.
Affected packages and fixed versions:
- youki (crates.io): affected all versions; fixed in 0.5.7
- youki (crates.io): affected all versions; fixed in 0.5.7
Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.
Reference: https://insights.sbomify.com/CVE-2025-62161/ (Markdown: https://insights.sbomify.com/CVE-2025-62161/index.md)
- Exploited in the wild
- Not known
- Fix
- Available
What is CVE-2025-62161?
CVE-2025-62161 is a high-severity vulnerability in youki-dev youki, published on 5 Nov 2025.
Official description
Youki is a container runtime written in Rust. In versions 0.5.6 and below, the initial validation of the source /dev/null is insufficient, allowing container escape when youki utilizes bind mounting the container's /dev/null as a file mask. This issue is fixed in version 0.5.7.
Which versions are affected by CVE-2025-62161?
2 open source packages ship an affected version, including youki. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
youki crates.io | All versions | 0.5.7 |
youki crates.io | All versions | 0.5.7 |
Products include Youki-Dev Youki.
How do I fix CVE-2025-62161?
Upgrade youki to 0.5.7 or later.
Is CVE-2025-62161 being exploited?
There is no known exploitation of CVE-2025-62161 in the wild and no public exploit code.
Other vulnerabilities in youki-dev youki
Sources
Also known as GHSA-4g74-7cff-xcv8.