# CVE-2025-62161: youki container escape via "masked path" abuse due to mount race conditions


- **Severity:** High 7.3 (`CVSS:4.0/AV:L/AC:L/AT:P/PR:L/UI:A/VC:H/VI:H/VA:H/SC:H/SI:H/SA:H`)
- **Exploited in the wild:** Not known
- **Fix available:** Yes
- **Published:** 5 Nov 2025
- **Updated:** 6 Nov 2025
- **Also known as:** GHSA-4g74-7cff-xcv8

## What is CVE-2025-62161?

CVE-2025-62161 is a high-severity vulnerability in youki-dev youki, published on 5 Nov 2025. 

### Official description

Youki is a container runtime written in Rust. In versions 0.5.6 and below, the initial validation of the source /dev/null is insufficient, allowing container escape when youki utilizes bind mounting the container's /dev/null as a file mask. This issue is fixed in version 0.5.7.

Weakness: CWE-61 (UNIX Symbolic Link (Symlink) Following), CWE-363 (Race Condition Enabling Link Following)

## Which versions are affected by CVE-2025-62161?

2 open source packages ship an affected version, including youki. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `youki` | crates.io | All versions | 0.5.7 |
| `youki` | crates.io | All versions | 0.5.7 |

Products: Youki-Dev Youki.

## How do I fix CVE-2025-62161?

Upgrade youki to 0.5.7 or later.

## Is CVE-2025-62161 being exploited?

There is no known exploitation of CVE-2025-62161 in the wild and no public exploit code.

## Other vulnerabilities in youki-dev youki

- [CVE-2025-62596](https://insights.sbomify.com/CVE-2025-62596/): youki container escape and denial of service due to arbitrary write gadgets and procfs write redirects (high 7.3)
- [CVE-2025-54867](https://insights.sbomify.com/CVE-2025-54867/): Youki Symlink Following Vulnerability (high 7.0)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-62161 and fix it if it is affected.

What it is: CVE-2025-62161 is a high-severity vulnerability in youki-dev youki, published on 5 Nov 2025. 
Exploitation: There is no known exploitation of CVE-2025-62161 in the wild and no public exploit code.

Affected packages and fixed versions:
- youki (crates.io): affected all versions; fixed in 0.5.7
- youki (crates.io): affected all versions; fixed in 0.5.7

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-62161/ (Markdown: https://insights.sbomify.com/CVE-2025-62161/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-62161
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-62161
- OSV: https://osv.dev/vulnerability/CVE-2025-62161

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-62161/
Summaries are generated and may contain mistakes; the official description above is the record.
