{"answers":{"affected":"2 open source packages ship an affected version, including cel.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-62162 exists.","fix":"Upgrade cel to 0.11.4 or later.","what":"CVE-2025-62162 is a high-severity denial of service vulnerability in cel-rust, published on 10 Oct 2025. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2025-62162 and fix it if it is affected.\n\nWhat it is: CVE-2025-62162 is a high-severity denial of service vulnerability in cel-rust, published on 10 Oct 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-62162 exists.\n\nAffected packages and fixed versions:\n- cel (crates.io): affected from 0.10.0; fixed in 0.11.4\n- cel (crates.io): affected from 0.10.0; fixed in 0.11.4\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-62162/ (Markdown: https://insights.sbomify.com/CVE-2025-62162/index.md)","id":"CVE-2025-62162","markdown":"https://insights.sbomify.com/CVE-2025-62162/index.md","name":"CVE-2025-62162","record":{"aliases":["GHSA-wxwx-9fh7-5mrw"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"Rust CEL interpreter","requires_auth":"none","summary":"Attackers can cause a denial of service by sending malformed CEL expressions to applications using the cel-rust library.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":7.5,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H","version":"3.1"},"cwes":[{"id":"CWE-20","name":"Improper Input Validation"}],"description":"cel-rust is a Common Expression Language interpreter written in Rust. Starting in version 0.10.0 and prior to version 0.11.4, parsing certain malformed CEL expressions can cause the parser to panic, terminating the process. When the crate is used to evaluate untrusted expressions (e.g., user-supplied input over an API), an attacker can send crafted input to trigger a denial of service (DoS). Version 0.11.4 fixes the issue.","ecosystems":["crates.io"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"cel-rust May Panic During Parsing of Invalid CEL Expressions","id":"CVE-2025-62162","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"crates.io","product":null,"products":[],"type":"denial_of_service","year":"2025"},"n_packages":2,"n_references":2,"next":{"headline":"VLLM deserialization vulnerability leading to DoS and potential RCE","id":"CVE-2025-62164"},"packages":[{"ecosystem":"crates.io","fixed":["0.11.4"],"introduced":["0.10.0"],"last_affected":[],"package":"cel","purl":null,"source":"GHSA-wxwx-9fh7-5mrw"},{"ecosystem":"crates.io","fixed":["0.11.4"],"introduced":["0.10.0"],"last_affected":[],"package":"cel","purl":"pkg:cargo/cel","source":"GHSA-wxwx-9fh7-5mrw"}],"prev":{"headline":"youki container escape via \"masked path\" abuse due to mount race conditions","id":"CVE-2025-62161"},"products":["cel-rust"],"published":"2025-10-10","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-10-14","vendors":["cel-rust"]},"summary":"Attackers can cause a denial of service by sending malformed CEL expressions to applications using the cel-rust library.","url":"https://insights.sbomify.com/CVE-2025-62162/"}