# CVE-2025-62162: cel-rust May Panic During Parsing of Invalid CEL Expressions

> Attackers can cause a denial of service by sending malformed CEL expressions to applications using the cel-rust library.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 10 Oct 2025
- **Updated:** 14 Oct 2025
- **Also known as:** GHSA-wxwx-9fh7-5mrw

## What is CVE-2025-62162?

CVE-2025-62162 is a high-severity denial of service vulnerability in cel-rust, published on 10 Oct 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

cel-rust is a Common Expression Language interpreter written in Rust. Starting in version 0.10.0 and prior to version 0.11.4, parsing certain malformed CEL expressions can cause the parser to panic, terminating the process. When the crate is used to evaluate untrusted expressions (e.g., user-supplied input over an API), an attacker can send crafted input to trigger a denial of service (DoS). Version 0.11.4 fixes the issue.

Weakness: CWE-20 (Improper Input Validation)

## Which versions are affected by CVE-2025-62162?

2 open source packages ship an affected version, including cel.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `cel` | crates.io | From 0.10.0 | 0.11.4 |
| `cel` | crates.io | From 0.10.0 | 0.11.4 |

## How do I fix CVE-2025-62162?

Upgrade cel to 0.11.4 or later.

## Is CVE-2025-62162 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-62162 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-62162 and fix it if it is affected.

What it is: CVE-2025-62162 is a high-severity denial of service vulnerability in cel-rust, published on 10 Oct 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-62162 exists.

Affected packages and fixed versions:
- cel (crates.io): affected from 0.10.0; fixed in 0.11.4
- cel (crates.io): affected from 0.10.0; fixed in 0.11.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-62162/ (Markdown: https://insights.sbomify.com/CVE-2025-62162/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-62162
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-62162
- OSV: https://osv.dev/vulnerability/CVE-2025-62162

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-62162/
Summaries are generated and may contain mistakes; the official description above is the record.
