CVE-2025-62164 VLLM deserialization vulnerability leading to DoS and potential RCE
Attackers can trigger memory corruption and potential remote code execution by sending malicious serialized tensors to the Completions API endpoint.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2025-62164?
CVE-2025-62164 is a high-severity unsafe deserialization vulnerability in Vllm Vllm, published on 21 Nov 2025. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
vLLM is an inference and serving engine for large language models (LLMs). From versions 0.10.2 to before 0.11.1, a memory corruption vulnerability could lead to a crash (denial-of-service) and potentially remote code execution (RCE), exists in the Completions API endpoint. When processing user-supplied prompt embeddings, the endpoint loads serialized tensors using torch.load() without sufficient validation. Due to a change introduced in PyTorch 2.8.0, sparse tensor integrity checks are disabled by default. As a result, maliciously crafted tensors can bypass internal bounds checks and trigger an out-of-bounds memory write during the call to to_dense(). This memory corruption can crash vLLM and potentially lead to code execution on the server hosting vLLM. This issue has been patched in version 0.11.1.
Which versions are affected by CVE-2025-62164?
3 open source packages ship an affected version, including vllm. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
vllm PyPI | From 0.10.2 | 0.11.1 |
vllm PyPI | From 0.10.2 | 0.11.1 |
vllm PyPI | From 0.10.2 | 0.11.1 |
Products include Vllm Vllm.
How do I fix CVE-2025-62164?
Upgrade vllm to 0.11.1 or later.
Upgrade, and only deserialise data from trusted sources or with an allow-list of types. More about Unsafe deserialization.
Is CVE-2025-62164 being exploited?
There is no known exploitation of CVE-2025-62164 in the wild and no public exploit code.
Other vulnerabilities in Vllm Vllm
- CVE-2025-32444 vLLM Vulnerable to Remote Code Execution via Mooncake Integration
- CVE-2026-22778 vLLM leaks a heap address when PIL throws an error
- CVE-2025-47277 vLLM Allows Remote Code Execution via PyNcclPipe Communication Service
- CVE-2024-11041 Remote Code Execution in vllm-project/vllm
- CVE-2026-48746 vLLM: OpenAI auth bypass
Sources
Also known as GHSA-mrw7-hf4f-83pf, PYSEC-2026-2018.