{"answers":{"affected":"3 open source packages ship an affected version, including vllm. It affects 1 product.","exploited":"There is no known exploitation of CVE-2025-62164 in the wild and no public exploit code.","fix":"Upgrade vllm to 0.11.1 or later.","what":"CVE-2025-62164 is a high-severity unsafe deserialization vulnerability in Vllm Vllm, published on 21 Nov 2025. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2025-62164 and fix it if it is affected.\n\nWhat it is: CVE-2025-62164 is a high-severity unsafe deserialization vulnerability in Vllm Vllm, published on 21 Nov 2025. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2025-62164 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- vllm (PyPI): affected from 0.10.2; fixed in 0.11.1\n- vllm (PyPI): affected from 0.10.2; fixed in 0.11.1\n- vllm (PyPI): affected from 0.10.2; fixed in 0.11.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-62164/ (Markdown: https://insights.sbomify.com/CVE-2025-62164/index.md)","id":"CVE-2025-62164","markdown":"https://insights.sbomify.com/CVE-2025-62164/index.md","name":"CVE-2025-62164","record":{"aliases":["GHSA-mrw7-hf4f-83pf","PYSEC-2026-2018"],"analysis":{"component_type":"server_software","fix_type":"upgrade","impacts":["code_execution","denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"LLM inference engine","requires_auth":"low_privilege","summary":"Attackers can trigger memory corruption and potential remote code execution by sending malicious serialized tensors to the Completions API endpoint.","user_interaction":"not_required","vuln_class":"deserialization"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"vllm","vendor":"vllm"}],"cvss":{"score":8.8,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-787","name":"Out-of-bounds Write"},{"id":"CWE-502","name":"Deserialization of Untrusted Data"},{"id":"CWE-20","name":"Improper Input Validation"},{"id":"CWE-123","name":"Write-what-where Condition"}],"description":"vLLM is an inference and serving engine for large language models (LLMs). From versions 0.10.2 to before 0.11.1, a memory corruption vulnerability could lead to a crash (denial-of-service) and potentially remote code execution (RCE), exists in the Completions API endpoint. When processing user-supplied prompt embeddings, the endpoint loads serialized tensors using torch.load() without sufficient validation. Due to a change introduced in PyTorch 2.8.0, sparse tensor integrity checks are disabled by default. As a result, maliciously crafted tensors can bypass internal bounds checks and trigger an out-of-bounds memory write during the call to to_dense(). This memory corruption can crash vLLM and potentially lead to code execution on the server hosting vLLM. This issue has been patched in version 0.11.1.","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"VLLM deserialization vulnerability leading to DoS and potential RCE","id":"CVE-2025-62164","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":"vllm:vllm","products":["vllm:vllm"],"type":"deserialization","year":"2025"},"n_packages":3,"n_references":3,"next":{"headline":"FreshRSS has an IDOR which allows for viewing feeds of any user and leaking tokens","id":"CVE-2025-62166"},"packages":[{"ecosystem":"PyPI","fixed":["0.11.1"],"introduced":["0.10.2"],"last_affected":[],"package":"vllm","purl":null,"source":"GHSA-mrw7-hf4f-83pf"},{"ecosystem":"PyPI","fixed":["0.11.1"],"introduced":["0.10.2"],"last_affected":[],"package":"vllm","purl":"pkg:pypi/vllm","source":"GHSA-mrw7-hf4f-83pf"},{"ecosystem":"PyPI","fixed":["0.11.1"],"introduced":["0.10.2"],"last_affected":[],"package":"vllm","purl":"pkg:pypi/vllm","source":"PYSEC-2026-2018"}],"prev":{"headline":"cel-rust May Panic During Parsing of Invalid CEL Expressions","id":"CVE-2025-62162"},"products":["vllm"],"published":"2025-11-21","related":[{"cvss_score":10,"headline":"vLLM Vulnerable to Remote Code Execution via Mooncake Integration","id":"CVE-2025-32444","kev_date_added":null,"published":"2025-04-30"},{"cvss_score":9.8,"headline":"vLLM leaks a heap address when PIL throws an error","id":"CVE-2026-22778","kev_date_added":null,"published":"2026-02-02"},{"cvss_score":9.8,"headline":"vLLM Allows Remote Code Execution via PyNcclPipe Communication Service","id":"CVE-2025-47277","kev_date_added":null,"published":"2025-05-20"},{"cvss_score":9.8,"headline":"Remote Code Execution in vllm-project/vllm","id":"CVE-2024-11041","kev_date_added":null,"published":"2025-03-20"},{"cvss_score":9.1,"headline":"vLLM: OpenAI auth bypass","id":"CVE-2026-48746","kev_date_added":null,"published":"2026-06-22"},{"cvss_score":9.1,"headline":"vLLM Allows Remote Code Execution via Mooncake Integration","id":"CVE-2025-29783","kev_date_added":null,"published":"2025-03-19"},{"cvss_score":8.8,"headline":"vLLM 0.9.2 before 0.24.0 SSRF via X-Request-Id in P2pNcclConnector","id":"CVE-2026-116176","kev_date_added":null,"published":"2026-10-25"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"total"},"state":"PUBLISHED","updated":"2025-11-24","vendors":["vllm-project"]},"summary":"Attackers can trigger memory corruption and potential remote code execution by sending malicious serialized tensors to the Completions API endpoint.","url":"https://insights.sbomify.com/CVE-2025-62164/"}