# CVE-2025-62164: VLLM deserialization vulnerability leading to DoS and potential RCE

> Attackers can trigger memory corruption and potential remote code execution by sending malicious serialized tensors to the Completions API endpoint.

- **Severity:** High 8.8 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 21 Nov 2025
- **Updated:** 24 Nov 2025
- **Also known as:** GHSA-mrw7-hf4f-83pf, PYSEC-2026-2018

## What is CVE-2025-62164?

CVE-2025-62164 is a high-severity unsafe deserialization vulnerability in Vllm Vllm, published on 21 Nov 2025. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

vLLM is an inference and serving engine for large language models (LLMs). From versions 0.10.2 to before 0.11.1, a memory corruption vulnerability could lead to a crash (denial-of-service) and potentially remote code execution (RCE), exists in the Completions API endpoint. When processing user-supplied prompt embeddings, the endpoint loads serialized tensors using torch.load() without sufficient validation. Due to a change introduced in PyTorch 2.8.0, sparse tensor integrity checks are disabled by default. As a result, maliciously crafted tensors can bypass internal bounds checks and trigger an out-of-bounds memory write during the call to to_dense(). This memory corruption can crash vLLM and potentially lead to code execution on the server hosting vLLM. This issue has been patched in version 0.11.1.

Weakness: CWE-787 (Out-of-bounds Write), CWE-502 (Deserialization of Untrusted Data), CWE-20 (Improper Input Validation), CWE-123 (Write-what-where Condition)

## Which versions are affected by CVE-2025-62164?

3 open source packages ship an affected version, including vllm. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `vllm` | PyPI | From 0.10.2 | 0.11.1 |
| `vllm` | PyPI | From 0.10.2 | 0.11.1 |
| `vllm` | PyPI | From 0.10.2 | 0.11.1 |

Products: Vllm Vllm.

## How do I fix CVE-2025-62164?

Upgrade vllm to 0.11.1 or later.

## Is CVE-2025-62164 being exploited?

There is no known exploitation of CVE-2025-62164 in the wild and no public exploit code.

## Other vulnerabilities in Vllm Vllm

- [CVE-2025-32444](https://insights.sbomify.com/CVE-2025-32444/): vLLM Vulnerable to Remote Code Execution via Mooncake Integration (critical 10.0)
- [CVE-2026-22778](https://insights.sbomify.com/CVE-2026-22778/): vLLM leaks a heap address when PIL throws an error (critical 9.8)
- [CVE-2025-47277](https://insights.sbomify.com/CVE-2025-47277/): vLLM Allows Remote Code Execution via PyNcclPipe Communication Service (critical 9.8)
- [CVE-2024-11041](https://insights.sbomify.com/CVE-2024-11041/): Remote Code Execution in vllm-project/vllm (critical 9.8)
- [CVE-2026-48746](https://insights.sbomify.com/CVE-2026-48746/): vLLM: OpenAI auth bypass (critical 9.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-62164 and fix it if it is affected.

What it is: CVE-2025-62164 is a high-severity unsafe deserialization vulnerability in Vllm Vllm, published on 21 Nov 2025. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-62164 in the wild and no public exploit code.

Affected packages and fixed versions:
- vllm (PyPI): affected from 0.10.2; fixed in 0.11.1
- vllm (PyPI): affected from 0.10.2; fixed in 0.11.1
- vllm (PyPI): affected from 0.10.2; fixed in 0.11.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-62164/ (Markdown: https://insights.sbomify.com/CVE-2025-62164/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-62164
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-62164
- OSV: https://osv.dev/vulnerability/CVE-2025-62164

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-62164/
Summaries are generated and may contain mistakes; the official description above is the record.
