CVE-2025-62169 OctoPrint-SpoolManager Plugin APIs do not enforce authentication
Unauthenticated attackers can access and modify spool management data via OctoPrint-SpoolManager plugin APIs.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- None listed
What is CVE-2025-62169?
CVE-2025-62169 is a high-severity missing authorization vulnerability in WildRikku OctoPrint-SpoolManager, published on 23 Oct 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
OctoPrint-SpoolManager is a plugin for managing spools and all their usage metadata. In versions 1.8.0a2 and older of the testing branch and versions 1.7.7 and older of the stable branch, the APIs of the OctoPrint-SpoolManager plugin do not correctly enforce authentication or authorization checks. This issue has been patched in versions 1.8.0a3 of the testing branch and 1.7.8 of the stable branch. The impact of this vulnerability is greatly reduced when using OctoPrint version 1.11.2 and newer.
Weakness: CWE-287
Which versions are affected by CVE-2025-62169?
How do I fix CVE-2025-62169?
No fix has been published for CVE-2025-62169 yet. Limit exposure of the affected software until one is available.
Upgrade, and check permissions on every request on the server, not only in the interface. More about Missing authorization.
Is CVE-2025-62169 being exploited?
There is no known exploitation of CVE-2025-62169 in the wild and no public exploit code.
Sources
Also known as GHSA-2rrc-f24f-94f6.