CVE-2025-62172 Home Assistant vulnerable to Stored XSS in Energy dashboard from Energy Entity Name
Authenticated attackers can inject malicious JavaScript into energy entity names, executing code in other users' sessions via dashboard tooltips.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2025-62172?
CVE-2025-62172 is a high-severity cross-site scripting vulnerability in home-assistant core, published on 14 Oct 2025. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Official description
Home Assistant is open source home automation software that puts local control and privacy first. In versions 2025.1.0 through 2025.10.1, the energy dashboard is vulnerable to stored cross-site scripting. An authenticated user can inject malicious JavaScript code into an energy entity's name field, which is then executed when any user hovers over data points in the energy dashboard graph tooltips. The vulnerability exists because entity names containing HTML are not properly sanitized before being rendered in graph tooltips. This could allow an attacker with authentication to execute arbitrary JavaScript in the context of other users' sessions. Additionally, if an energy provider (such as Tibber) supplies a malicious default name for an entity, the vulnerability can be exploited without direct user action when the default name is used. This issue has been patched in version 2025.10.2. No known workarounds exist.
Which versions are affected by CVE-2025-62172?
3 open source packages ship an affected version, including homeassistant.
| Package | Affected | Fixed in |
|---|---|---|
homeassistant PyPI | From 2025.1.0 | 2025.10.2 |
homeassistant PyPI | From 2025.1.0 | 2025.10.2 |
homeassistant PyPI | From 2025.1.0 | 2025.10.2 |
How do I fix CVE-2025-62172?
Upgrade homeassistant to 2025.10.2 or later.
Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.
Is CVE-2025-62172 being exploited?
It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-62172 exists.
Sources
Also known as GHSA-mq77-rv97-285m, PYSEC-2026-1453.