{"answers":{"affected":"3 open source packages ship an affected version, including homeassistant.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-62172 exists.","fix":"Upgrade homeassistant to 2025.10.2 or later.","what":"CVE-2025-62172 is a high-severity cross-site scripting vulnerability in home-assistant core, published on 14 Oct 2025. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2025-62172 and fix it if it is affected.\n\nWhat it is: CVE-2025-62172 is a high-severity cross-site scripting vulnerability in home-assistant core, published on 14 Oct 2025. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-62172 exists.\n\nAffected packages and fixed versions:\n- homeassistant (PyPI): affected from 2025.1.0; fixed in 2025.10.2\n- homeassistant (PyPI): affected from 2025.1.0; fixed in 2025.10.2\n- homeassistant (PyPI): affected from 2025.1.0; fixed in 2025.10.2\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-62172/ (Markdown: https://insights.sbomify.com/CVE-2025-62172/index.md)","id":"CVE-2025-62172","markdown":"https://insights.sbomify.com/CVE-2025-62172/index.md","name":"CVE-2025-62172","record":{"aliases":["GHSA-mq77-rv97-285m","PYSEC-2026-1453"],"analysis":{"component_type":"web_application","fix_type":"patch","impacts":["code_execution","account_takeover"],"network_reachable":"yes","non_default_config":false,"product_category":"Home automation software","requires_auth":"low_privilege","summary":"Authenticated attackers can inject malicious JavaScript into energy entity names, executing code in other users' sessions via dashboard tooltips.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":8.5,"severity":"high","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:A/VC:H/VI:H/VA:H/SC:H/SI:H/SA:H/E:P","version":"4.0"},"cwes":[{"id":"CWE-80","name":"Improper Neutralization of Script-Related HTML Tags in a Web Page"},{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"Home Assistant is open source home automation software that puts local control and privacy first. In versions 2025.1.0 through 2025.10.1, the energy dashboard is vulnerable to stored cross-site scripting. An authenticated user can inject malicious JavaScript code into an energy entity's name field, which is then executed when any user hovers over data points in the energy dashboard graph tooltips. The vulnerability exists because entity names containing HTML are not properly sanitized before being rendered in graph tooltips. This could allow an attacker with authentication to execute arbitrary JavaScript in the context of other users' sessions. Additionally, if an energy provider (such as Tibber) supplies a malicious default name for an entity, the vulnerability can be exploited without direct user action when the default name is used. This issue has been patched in version 2025.10.2. No known workarounds exist.","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"Home Assistant vulnerable to Stored XSS in Energy dashboard from Energy Entity Name","id":"CVE-2025-62172","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"xss","year":"2025"},"n_packages":3,"n_references":1,"next":{"headline":"Authenticated SQL Injection in Endpoint Module Rest API","id":"CVE-2025-62173"},"packages":[{"ecosystem":"PyPI","fixed":["2025.10.2"],"introduced":["2025.1.0"],"last_affected":[],"package":"homeassistant","purl":null,"source":"GHSA-mq77-rv97-285m"},{"ecosystem":"PyPI","fixed":["2025.10.2"],"introduced":["2025.1.0"],"last_affected":[],"package":"homeassistant","purl":"pkg:pypi/homeassistant","source":"GHSA-mq77-rv97-285m"},{"ecosystem":"PyPI","fixed":["2025.10.2"],"introduced":["2025.1.0"],"last_affected":[],"package":"homeassistant","purl":"pkg:pypi/homeassistant","source":"PYSEC-2026-1453"}],"prev":{"headline":"ImageMagick vulnerable to denial of service via integer overflow in BMP decoder on 32-bit systems","id":"CVE-2025-62171"},"products":["core"],"published":"2025-10-14","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-10-21","vendors":["home-assistant"]},"summary":"Authenticated attackers can inject malicious JavaScript into energy entity names, executing code in other users' sessions via dashboard tooltips.","url":"https://insights.sbomify.com/CVE-2025-62172/"}