# CVE-2025-62190: CSRF Allows Call Initiation and Message Delivery

> An authenticated attacker can initiate calls and inject messages into channels via a malicious webpage due to missing CSRF protection in the Calls widget.

- **Severity:** Medium 4.3 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 17 Dec 2025
- **Updated:** 17 Dec 2025
- **Also known as:** GHSA-gmx5-frv9-9m9f, GO-2025-4254

## What is CVE-2025-62190?

CVE-2025-62190 is a medium-severity vulnerability in Mattermost Mattermost Server, published on 17 Dec 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Mattermost versions 11.0.x <= 11.0.4, 10.12.x <= 10.12.2, 10.11.x <= 10.11.6 and Mattermost Calls versions <=1.10.0 fail to implement CSRF protection on the Calls widget page which allows an authenticated attacker to initiate calls and inject messages into channels or direct messages via a malicious webpage or crafted link

Weakness: CWE-352 (Cross-Site Request Forgery)

## Which versions are affected by CVE-2025-62190?

3 open source packages ship an affected version, including github.com/mattermost/mattermost-plugin-calls. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/mattermost/mattermost-plugin-calls` | Go | All versions | 1.10.0 |
| `github.com/mattermost/mattermost-plugin-calls` | Go | All versions | 1.10.0 |
| `github.com/mattermost/mattermost-plugin-calls` | Go | All versions | 1.10.0 |

Products: Mattermost Mattermost Server.

## How do I fix CVE-2025-62190?

Upgrade github.com/mattermost/mattermost-plugin-calls to 1.10.0 or later.

## Is CVE-2025-62190 being exploited?

There is no known exploitation of CVE-2025-62190 in the wild and no public exploit code.

## Other vulnerabilities in Mattermost Mattermost Server

- [CVE-2025-12419](https://insights.sbomify.com/CVE-2025-12419/): Account takeover on OAuth/OpenID-enabled servers (critical 9.9)
- [CVE-2025-12421](https://insights.sbomify.com/CVE-2025-12421/): Account Takeover via Code Exchange Endpoint (critical 9.9)
- [CVE-2025-4981](https://insights.sbomify.com/CVE-2025-4981/): Path Traversal Leading to RCE by Any Authenticated Mattermost User (critical 9.9)
- [CVE-2025-20051](https://insights.sbomify.com/CVE-2025-20051/): Arbitrary file read via block duplication in Mattermost Boards (critical 9.9)
- [CVE-2025-25279](https://insights.sbomify.com/CVE-2025-25279/): Arbitrary file read in Mattermost Boards via import & export board archive (critical 9.9)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-62190 and fix it if it is affected.

What it is: CVE-2025-62190 is a medium-severity vulnerability in Mattermost Mattermost Server, published on 17 Dec 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2025-62190 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/mattermost/mattermost-plugin-calls (Go): affected all versions; fixed in 1.10.0
- github.com/mattermost/mattermost-plugin-calls (Go): affected all versions; fixed in 1.10.0
- github.com/mattermost/mattermost-plugin-calls (Go): affected all versions; fixed in 1.10.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-62190/ (Markdown: https://insights.sbomify.com/CVE-2025-62190/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-62190
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-62190
- OSV: https://osv.dev/vulnerability/CVE-2025-62190

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-62190/
Summaries are generated and may contain mistakes; the official description above is the record.
