CVE-2025-62198 Apache Atlas: Stored XSS in Create Entity page

Medium 5.4 Published Updated

An authenticated user can inject malicious scripts into the Create Entity page, potentially leading to session hijacking or code execution.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
Available

What is CVE-2025-62198?

CVE-2025-62198 is a medium-severity cross-site scripting vulnerability in Apache Atlas, published on 22 Jun 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

Official description

An authenticated user can perform XSS.

This issue affects Apache Atlas versions 2.4.0 and earlier.

Users are recommended to upgrade to version 2.5.0, which fixes the issue.

Weakness: CWE-80

Which versions are affected by CVE-2025-62198?

2 open source packages ship an affected version, including org.apache.atlas:atlas-dashboardv2. It affects 1 product.

PackageAffectedFixed in
org.apache.atlas:atlas-dashboardv2 MavenAll versions2.5.0
org.apache.atlas:atlas-dashboardv2 MavenAll versions2.5.0

Products include Apache Atlas.

How do I fix CVE-2025-62198?

Upgrade org.apache.atlas:atlas-dashboardv2 to 2.5.0 or later.

Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.

Is CVE-2025-62198 being exploited?

There is no known exploitation of CVE-2025-62198 in the wild and no public exploit code.

Sources

Also known as GHSA-v73p-f52r-fmmr.

Is CVE-2025-62198 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free