# CVE-2025-62198: Apache Atlas: Stored XSS in Create Entity page

> An authenticated user can inject malicious scripts into the Create Entity page, potentially leading to session hijacking or code execution.

- **Severity:** Medium 5.4 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 22 Jun 2026
- **Updated:** 22 Jun 2026
- **Also known as:** GHSA-v73p-f52r-fmmr

## What is CVE-2025-62198?

CVE-2025-62198 is a medium-severity cross-site scripting vulnerability in Apache Atlas, published on 22 Jun 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

An authenticated user can perform XSS.

This issue affects Apache Atlas versions 2.4.0 and earlier.

Users are recommended to upgrade to version 2.5.0, which fixes the issue.

Weakness: CWE-80 (Improper Neutralization of Script-Related HTML Tags in a Web Page)

## Which versions are affected by CVE-2025-62198?

2 open source packages ship an affected version, including org.apache.atlas:atlas-dashboardv2. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.apache.atlas:atlas-dashboardv2` | Maven | All versions | 2.5.0 |
| `org.apache.atlas:atlas-dashboardv2` | Maven | All versions | 2.5.0 |

Products: Apache Atlas.

## How do I fix CVE-2025-62198?

Upgrade org.apache.atlas:atlas-dashboardv2 to 2.5.0 or later.

## Is CVE-2025-62198 being exploited?

There is no known exploitation of CVE-2025-62198 in the wild and no public exploit code.

## Other vulnerabilities in Apache Atlas

- [CVE-2026-50622](https://insights.sbomify.com/CVE-2026-50622/): Apache Atlas: Missing Authorization on Admin Endpoints (high 8.8)
- [CVE-2022-34271](https://insights.sbomify.com/CVE-2022-34271/): Apache Atlas: zip path traversal in import functionality (high 8.8)
- [CVE-2026-40563](https://insights.sbomify.com/CVE-2026-40563/): Apache Atlas: Script injection allows access to unintended data (high 8.1)
- [CVE-2016-8752](https://insights.sbomify.com/CVE-2016-8752/): Path Traversal in Apache Atlas (high 7.5)
- [CVE-2017-3154](https://insights.sbomify.com/CVE-2017-3154/): Apache Atlas produces Stack trace in error response (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-62198 and fix it if it is affected.

What it is: CVE-2025-62198 is a medium-severity cross-site scripting vulnerability in Apache Atlas, published on 22 Jun 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2025-62198 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.apache.atlas:atlas-dashboardv2 (Maven): affected all versions; fixed in 2.5.0
- org.apache.atlas:atlas-dashboardv2 (Maven): affected all versions; fixed in 2.5.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-62198/ (Markdown: https://insights.sbomify.com/CVE-2025-62198/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-62198
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-62198
- OSV: https://osv.dev/vulnerability/CVE-2025-62198

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-62198/
Summaries are generated and may contain mistakes; the official description above is the record.
