# CVE-2025-62228: Apache Flink CDC is vulnerable to SQL Injection through maliciously crafted identifiers


- **Severity:** Medium 5.1 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:H/UI:N/VC:L/VI:L/VA:L/SC:L/SI:L/SA:L/R:U/V:C/RE:L/U:Amber`)
- **Exploited in the wild:** Not known
- **Fix available:** Yes
- **Published:** 9 Oct 2025
- **Updated:** 4 Nov 2025
- **Also known as:** GHSA-wqm3-w3p6-xjgm

## What is CVE-2025-62228?

CVE-2025-62228 is a medium-severity vulnerability in Apache Flink CDC, published on 9 Oct 2025. 

### Official description

Apache Flink CDC version 3.4.0 was vulnerable to a SQL injection via maliciously crafted identifiers eg. crafted database name or crafted table name. Even through only the logged-in database user can trigger the attack, we recommend users update Flink CDC version to 3.5.0 which address this issue.

Weakness: CWE-89 (Improper Neutralization of Special Elements used in an SQL Command)

## Which versions are affected by CVE-2025-62228?

10 open source packages ship an affected version, including org.apache.flink:flink-cdc-pipeline-connectors, org.apache.flink:flink-connector-db2-cdc and org.apache.flink:flink-connector-mysql-cdc. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.apache.flink:flink-cdc-pipeline-connectors` | Maven | From 3.0.0 | 3.5.0 |
| `org.apache.flink:flink-cdc-pipeline-connectors` | Maven | From 3.0.0 | 3.5.0 |
| `org.apache.flink:flink-connector-db2-cdc` | Maven | From 3.0.0 | 3.5.0 |
| `org.apache.flink:flink-connector-db2-cdc` | Maven | From 3.0.0 | 3.5.0 |
| `org.apache.flink:flink-connector-mysql-cdc` | Maven | From 3.0.0 | 3.5.0 |
| `org.apache.flink:flink-connector-mysql-cdc` | Maven | From 3.0.0 | 3.5.0 |
| `org.apache.flink:flink-connector-oracle-cdc` | Maven | From 3.0.0 | 3.5.0 |
| `org.apache.flink:flink-connector-oracle-cdc` | Maven | From 3.0.0 | 3.5.0 |
| `org.apache.flink:flink-connector-sqlserver-cdc` | Maven | From 3.0.0 | 3.5.0 |
| `org.apache.flink:flink-connector-sqlserver-cdc` | Maven | From 3.0.0 | 3.5.0 |

Products: Apache Flink Cdc.

## How do I fix CVE-2025-62228?

Upgrade org.apache.flink:flink-cdc-pipeline-connectors to 3.5.0 or later.

## Is CVE-2025-62228 being exploited?

There is no known exploitation of CVE-2025-62228 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-62228 and fix it if it is affected.

What it is: CVE-2025-62228 is a medium-severity vulnerability in Apache Flink CDC, published on 9 Oct 2025. 
Exploitation: There is no known exploitation of CVE-2025-62228 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.apache.flink:flink-cdc-pipeline-connectors (Maven): affected from 3.0.0; fixed in 3.5.0
- org.apache.flink:flink-cdc-pipeline-connectors (Maven): affected from 3.0.0; fixed in 3.5.0
- org.apache.flink:flink-connector-db2-cdc (Maven): affected from 3.0.0; fixed in 3.5.0
- org.apache.flink:flink-connector-db2-cdc (Maven): affected from 3.0.0; fixed in 3.5.0
- org.apache.flink:flink-connector-mysql-cdc (Maven): affected from 3.0.0; fixed in 3.5.0
- org.apache.flink:flink-connector-mysql-cdc (Maven): affected from 3.0.0; fixed in 3.5.0
- org.apache.flink:flink-connector-oracle-cdc (Maven): affected from 3.0.0; fixed in 3.5.0
- org.apache.flink:flink-connector-oracle-cdc (Maven): affected from 3.0.0; fixed in 3.5.0
- org.apache.flink:flink-connector-sqlserver-cdc (Maven): affected from 3.0.0; fixed in 3.5.0
- org.apache.flink:flink-connector-sqlserver-cdc (Maven): affected from 3.0.0; fixed in 3.5.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-62228/ (Markdown: https://insights.sbomify.com/CVE-2025-62228/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-62228
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-62228
- OSV: https://osv.dev/vulnerability/CVE-2025-62228

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-62228/
Summaries are generated and may contain mistakes; the official description above is the record.
