CVE-2025-62232 Apache APISIX: basic-auth logs plaintext credentials at info level
Attackers with log access can steal plaintext credentials from Apache APISIX logs when INFO or DEBUG levels are enabled.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2025-62232?
CVE-2025-62232 is a high-severity vulnerability in Apache APISIX, published on 31 Oct 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
Sensitive data exposure via logging in basic-auth leads to plaintext usernames and passwords written to error logs and forwarded to log sinks when log level is INFO/DEBUG. This creates a high risk of credential compromise through log access. It has been fixed in the following commit: https://github.com/apache/apisix/pull/12629 Users are recommended to upgrade to version 3.14, which fixes this issue.
Weakness: CWE-532
Which versions are affected by CVE-2025-62232?
1 open source package ship an affected version, including apisix. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
apisix Bitnami | From 1.0.0 | 3.14.0 |
Products include Apache Apisix.
How do I fix CVE-2025-62232?
Upgrade apisix to 3.14.0 or later.
Is CVE-2025-62232 being exploited?
There is no known exploitation of CVE-2025-62232 in the wild and no public exploit code.
Other vulnerabilities in Apache APISIX
- CVE-2022-24112 Apache APISIX Authentication Bypass
- CVE-2022-25757 Apache APISIX: the body_schema check in request-validation plugin can be bypassed
- CVE-2026-31908 Apache APISIX: forward auth plugin allows header injection
- CVE-2026-75005 Apache APISIX: Unauthenticated CPU-exhaustion DoS
- CVE-2025-27446 Privilege escalation in Apache APISIX Java Plugin Runner
Sources
Also known as BIT-apisix-2025-62232, GHSA-3h2w-68px-r4v5.