CVE-2025-62233 Apache DolphinScheduler: Deserialization of untrusted data in RPC
Attackers with network access to Master or Worker nodes can execute arbitrary code by sending malicious RPC requests containing untrusted serialized data.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2025-62233?
CVE-2025-62233 is a medium-severity unsafe deserialization vulnerability in Apache DolphinScheduler, published on 24 Apr 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
Deserialization of Untrusted Data vulnerability in Apache DolphinScheduler RPC module.
This issue affects Apache DolphinScheduler:
Version >= 3.2.0 and < 3.3.1.
Attackers who can access the Master or Worker nodes can compromise the system by creating a StandardRpcRequest, injecting a malicious class type into it, and sending RPC requests to the DolphinScheduler Master/Worker nodes. Users are recommended to upgrade to version [3.3.1], which fixes the issue.
Weakness: CWE-502
Which versions are affected by CVE-2025-62233?
4 open source packages ship an affected version, including org.apache.dolphinscheduler:dolphinscheduler and org.apache.dolphinscheduler:dolphinscheduler-rpc. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
org.apache.dolphinscheduler:dolphinscheduler Maven | From 3.2.0 | 3.3.1 |
org.apache.dolphinscheduler:dolphinscheduler Maven | From 3.2.0 | 3.3.1 |
org.apache.dolphinscheduler:dolphinscheduler-rpc Maven | From 3.2.0 | 3.3.1 |
org.apache.dolphinscheduler:dolphinscheduler-rpc Maven | From 3.2.0 | 3.3.1 |
Products include Apache Dolphinscheduler.
How do I fix CVE-2025-62233?
Upgrade org.apache.dolphinscheduler:dolphinscheduler to 3.3.1 or later.
Upgrade, and only deserialise data from trusted sources or with an allow-list of types. More about Unsafe deserialization.
Is CVE-2025-62233 being exploited?
There is no known exploitation of CVE-2025-62233 in the wild and no public exploit code.
Other vulnerabilities in Apache DolphinScheduler
- CVE-2024-43166 Apache DolphinScheduler Incorrect Default Permissions Vulnerability
- CVE-2024-43202 Apache DolphinScheduler: Remote Code Execution Vulnerability
- CVE-2023-49109 Remote Code Execution in Apache Dolphinscheduler
- CVE-2022-45875 Apache DolphinScheduler: Remote command execution Vulnerability in script alert plugin
- CVE-2022-45462 Apache DolphinScheduler prior to 2.0.5 have command execution vulnerability
Sources
Also known as GHSA-f786-9c63-8xr8.