# CVE-2025-62233: Apache DolphinScheduler: Deserialization of untrusted data in RPC

> Attackers with network access to Master or Worker nodes can execute arbitrary code by sending malicious RPC requests containing untrusted serialized data.

- **Severity:** Medium 6.3 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 24 Apr 2026
- **Updated:** 24 Apr 2026
- **Also known as:** GHSA-f786-9c63-8xr8

## What is CVE-2025-62233?

CVE-2025-62233 is a medium-severity unsafe deserialization vulnerability in Apache DolphinScheduler, published on 24 Apr 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Deserialization of Untrusted Data vulnerability in Apache DolphinScheduler RPC module.

This issue affects Apache DolphinScheduler: 

Version >= 3.2.0 and < 3.3.1.

Attackers who can access the Master or Worker nodes can compromise the system by creating a StandardRpcRequest, injecting a malicious class type into it, and sending RPC requests to the DolphinScheduler Master/Worker nodes.
Users are recommended to upgrade to version [3.3.1], which fixes the issue.

Weakness: CWE-502 (Deserialization of Untrusted Data)

## Which versions are affected by CVE-2025-62233?

4 open source packages ship an affected version, including org.apache.dolphinscheduler:dolphinscheduler and org.apache.dolphinscheduler:dolphinscheduler-rpc. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.apache.dolphinscheduler:dolphinscheduler` | Maven | From 3.2.0 | 3.3.1 |
| `org.apache.dolphinscheduler:dolphinscheduler` | Maven | From 3.2.0 | 3.3.1 |
| `org.apache.dolphinscheduler:dolphinscheduler-rpc` | Maven | From 3.2.0 | 3.3.1 |
| `org.apache.dolphinscheduler:dolphinscheduler-rpc` | Maven | From 3.2.0 | 3.3.1 |

Products: Apache Dolphinscheduler.

## How do I fix CVE-2025-62233?

Upgrade org.apache.dolphinscheduler:dolphinscheduler to 3.3.1 or later.

## Is CVE-2025-62233 being exploited?

There is no known exploitation of CVE-2025-62233 in the wild and no public exploit code.

## Other vulnerabilities in Apache DolphinScheduler

- [CVE-2024-43166](https://insights.sbomify.com/CVE-2024-43166/): Apache DolphinScheduler Incorrect Default Permissions Vulnerability (critical 9.8)
- [CVE-2024-43202](https://insights.sbomify.com/CVE-2024-43202/): Apache DolphinScheduler: Remote Code Execution Vulnerability (critical 9.8)
- [CVE-2023-49109](https://insights.sbomify.com/CVE-2023-49109/): Remote Code Execution in Apache Dolphinscheduler (critical 9.8)
- [CVE-2022-45875](https://insights.sbomify.com/CVE-2022-45875/): Apache DolphinScheduler: Remote command execution Vulnerability in script alert plugin (critical 9.8)
- [CVE-2022-45462](https://insights.sbomify.com/CVE-2022-45462/): Apache DolphinScheduler prior to 2.0.5 have command execution vulnerability (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-62233 and fix it if it is affected.

What it is: CVE-2025-62233 is a medium-severity unsafe deserialization vulnerability in Apache DolphinScheduler, published on 24 Apr 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-62233 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.apache.dolphinscheduler:dolphinscheduler (Maven): affected from 3.2.0; fixed in 3.3.1
- org.apache.dolphinscheduler:dolphinscheduler (Maven): affected from 3.2.0; fixed in 3.3.1
- org.apache.dolphinscheduler:dolphinscheduler-rpc (Maven): affected from 3.2.0; fixed in 3.3.1
- org.apache.dolphinscheduler:dolphinscheduler-rpc (Maven): affected from 3.2.0; fixed in 3.3.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-62233/ (Markdown: https://insights.sbomify.com/CVE-2025-62233/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-62233
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-62233
- OSV: https://osv.dev/vulnerability/CVE-2025-62233

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-62233/
Summaries are generated and may contain mistakes; the official description above is the record.
