CVE-2025-62235 Apache Mynewt NimBLE: Incorrect handling of SMP Security Request could lead to undesirable pairing

High 8.1 Published Updated

Attackers can spoof Security Requests to remove original bonds and re-bond with an impostor, bypassing authentication in Apache NimBLE.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Local or same network only
Victim action needed
Not needed
Fix
None listed

What is CVE-2025-62235?

CVE-2025-62235 is a high-severity authentication bypass vulnerability in Apache Mynewt NimBLE, published on 10 Jan 2026. It can only be exploited from the same machine or local network, with no action from the victim.

Official description

Authentication Bypass by Spoofing vulnerability in Apache NimBLE.

Receiving specially crafted Security Request could lead to removal of original bond and re-bond with impostor. This issue affects Apache NimBLE: through 1.8.0.

Users are recommended to upgrade to version 1.9.0, which fixes the issue.

Weakness: CWE-290

Which versions are affected by CVE-2025-62235?

It affects 1 product.

Products include Apache Nimble.

How do I fix CVE-2025-62235?

No fix has been published for CVE-2025-62235 yet. Limit exposure of the affected software until one is available.

Upgrade, and rotate credentials and sessions that may have been exposed. More about Authentication bypass.

Is CVE-2025-62235 being exploited?

There is no known exploitation of CVE-2025-62235 in the wild and no public exploit code.

Sources

Also known as GHSA-8mfp-xmv3-hv35.

Is CVE-2025-62235 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free