CVE-2025-6226 IDOR in CreatePost API allows for timeboxed message disclosure
Authenticated attackers can read private channel messages by guessing PendingPostIDs due to missing authorization checks in the CreatePost API.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2025-6226?
CVE-2025-6226 is a medium-severity missing authorization vulnerability in Mattermost Mattermost Server, published on 18 Jul 2025. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
Mattermost versions 10.5.x <= 10.5.6, 10.8.x <= 10.8.1, 10.7.x <= 10.7.3, 9.11.x <= 9.11.16 fail to verify authorization when retrieving cached posts by PendingPostID which allows an authenticated user to read posts in private channels they don't have access to via guessing the PendingPostID of recently created posts.
Weakness: CWE-306
Which versions are affected by CVE-2025-6226?
14 open source packages ship an affected version, including github.com/mattermost/mattermost-server, github.com/mattermost/mattermost-server/v5 and github.com/mattermost/mattermost-server/v6. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
github.com/mattermost/mattermost-server Go | From 10.5.0 | 10.5.7 |
github.com/mattermost/mattermost-server Go | From 10.5.0 | 10.5.7 |
github.com/mattermost/mattermost-server Go | From 10.7.0 | 10.7.4 |
github.com/mattermost/mattermost-server Go | From 10.7.0 | 10.7.4 |
github.com/mattermost/mattermost-server Go | From 10.8.0 | 10.8.2 |
github.com/mattermost/mattermost-server Go | From 10.8.0 | 10.8.2 |
8 more packages
github.com/mattermost/mattermost-server Go | From 9.11.0 | 9.11.17 |
github.com/mattermost/mattermost-server Go | From 9.11.0 | 9.11.17 |
github.com/mattermost/mattermost-server Go | From 9.11.0+incompatible | 9.11.17+incompatible, 10.5.7+incompatible, 10.7.4+incompatible, 10.8.2+incompatible |
github.com/mattermost/mattermost-server/v5 Go | All versions | None |
github.com/mattermost/mattermost-server/v6 Go | All versions | None |
github.com/mattermost/mattermost/server/v8 Go | All versions | 8.0.0-20250520130510-fa40a8c5d47f |
github.com/mattermost/mattermost/server/v8 Go | All versions | 8.0.0-20250520130510-fa40a8c5d47f |
github.com/mattermost/mattermost/server/v8 Go | All versions | 8.0.0-20250520130510-fa40a8c5d47f |
Products include Mattermost Mattermost Server.
How do I fix CVE-2025-6226?
Upgrade github.com/mattermost/mattermost-server to a fixed version for your release line: 10.5.7, 10.7.4, 10.8.2 or 9.11.17.
Upgrade, and check permissions on every request on the server, not only in the interface. More about Missing authorization.
Is CVE-2025-6226 being exploited?
There is no known exploitation of CVE-2025-6226 in the wild and no public exploit code.
Other vulnerabilities in Mattermost Mattermost Server
- CVE-2025-12419 Account takeover on OAuth/OpenID-enabled servers
- CVE-2025-12421 Account Takeover via Code Exchange Endpoint
- CVE-2025-4981 Path Traversal Leading to RCE by Any Authenticated Mattermost User
- CVE-2025-20051 Arbitrary file read via block duplication in Mattermost Boards
- CVE-2025-25279 Arbitrary file read in Mattermost Boards via import & export board archive
Sources
Also known as GHSA-7h34-9chr-58qh, GO-2025-3819.