# CVE-2025-62263: Liferay Portal Vulnerable to Cross-Site Scripting

> Remote attackers can inject arbitrary web script or HTML via crafted payloads in Account Role or Organization fields, potentially leading to session hijacking or malicious actions.

- **Severity:** Medium 4.8 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:A/VC:L/VI:L/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 27 Oct 2025
- **Updated:** 27 Oct 2025
- **Also known as:** GHSA-8mgf-rgg5-w38q

## What is CVE-2025-62263?

CVE-2025-62263 is a medium-severity cross-site scripting vulnerability in Liferay Digital Experience Platform, published on 27 Oct 2025. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

Multiple cross-site scripting (XSS) vulnerabilities in Liferay Portal 7.3.7 through 7.4.3.103, and Liferay DXP 2023.Q3.1 through 2023.Q3.4, 7.4 GA through update 92, 7.3 service pack 3 through update 36 allow remote attackers to inject arbitrary web script or HTML via a crafted payload injected into an Account Role’s “Title” text field to (1) view account role page, or (2) select account role page.

Multiple cross-site scripting (XSS) vulnerabilities in Liferay Portal 7.3.7 through 7.4.3.103, and Liferay DXP 2023.Q3.1 through 2023.Q3.4, 7.4 GA through update 92, 7.3 service pack 3 through update 36 allow remote attackers to inject arbitrary web script or HTML via a crafted payload injected into an Organization’s “Name” text field to (1) view account page, (2) view account organization page, or (3) select account organization page.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2025-62263?

2 open source packages ship an affected version, including com.liferay:com.liferay.account.admin.web. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `com.liferay:com.liferay.account.admin.web` | Maven | From 2.0.0 | 2.0.108 |
| `com.liferay:com.liferay.account.admin.web` | Maven | From 2.0.0 | 2.0.108 |

Products: Liferay Digital Experience Platform, Liferay Liferay Portal.

## How do I fix CVE-2025-62263?

Upgrade com.liferay:com.liferay.account.admin.web to 2.0.108 or later.

## Is CVE-2025-62263 being exploited?

There is no known exploitation of CVE-2025-62263 in the wild and no public exploit code.

## Other vulnerabilities in Liferay Digital Experience Platform

- [CVE-2024-8980](https://insights.sbomify.com/CVE-2024-8980/): Liferay Portal and Liferay DXP Vulnerable to CSRF in the Script Console (critical 9.6)
- [CVE-2023-42496](https://insights.sbomify.com/CVE-2023-42496/): Liferay Portal and Liferay DXP vulnerable to reflected Cross-site Scripting (critical 9.6)
- [CVE-2023-42498](https://insights.sbomify.com/CVE-2023-42498/): Liferay Portal Language Override edit screen and Liferay DXP vulnerable to reflected Cross-site Scripting (critical 9.6)
- [CVE-2024-25147](https://insights.sbomify.com/CVE-2024-25147/): Liferay Portal and Liferay DXP vulnerable to Cross-site Scripting (critical 9.6)
- [CVE-2024-26269](https://insights.sbomify.com/CVE-2024-26269/): Liferay Portal Frontend JS module's portlet.js and Liferay DXP vulnerable to Cross-site Scripting (critical 9.6)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-62263 and fix it if it is affected.

What it is: CVE-2025-62263 is a medium-severity cross-site scripting vulnerability in Liferay Digital Experience Platform, published on 27 Oct 2025. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2025-62263 in the wild and no public exploit code.

Affected packages and fixed versions:
- com.liferay:com.liferay.account.admin.web (Maven): affected from 2.0.0; fixed in 2.0.108
- com.liferay:com.liferay.account.admin.web (Maven): affected from 2.0.0; fixed in 2.0.108

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-62263/ (Markdown: https://insights.sbomify.com/CVE-2025-62263/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-62263
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-62263
- OSV: https://osv.dev/vulnerability/CVE-2025-62263

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-62263/
Summaries are generated and may contain mistakes; the official description above is the record.
