CVE-2025-6227 Invite token is used as part of the secure communication
Attackers intercepting invite tokens can bypass security checks to send unauthorized synchronization payloads to the server.
- Exploited in the wild
- Not known
- Login needed
- An administrator
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2025-6227?
CVE-2025-6227 is a low-severity vulnerability in Mattermost Mattermost Server, published on 18 Jul 2025. An attacker needs administrator access to exploit it, with no action from the victim.
Official description
Mattermost versions 10.5.x <= 10.5.7, 9.11.x <= 9.11.16 fail to negotiate a new token when accepting the invite which allows a user that intercepts both invite and password to send synchronization payloads to the server that originally created the invite via the REST API.
Weakness: CWE-522
Which versions are affected by CVE-2025-6227?
10 open source packages ship an affected version, including github.com/mattermost/mattermost-server, github.com/mattermost/mattermost-server/v5 and github.com/mattermost/mattermost-server/v6. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
github.com/mattermost/mattermost-server Go | From 10.5.0 | 10.5.8 |
github.com/mattermost/mattermost-server Go | From 10.5.0 | 10.5.8 |
github.com/mattermost/mattermost-server Go | From 9.11.0 | 9.11.17 |
github.com/mattermost/mattermost-server Go | From 9.11.0 | 9.11.17 |
github.com/mattermost/mattermost-server Go | From 9.11.0+incompatible | 9.11.17+incompatible, 10.5.8+incompatible |
github.com/mattermost/mattermost-server/v5 Go | All versions | None |
4 more packages
github.com/mattermost/mattermost-server/v6 Go | All versions | None |
github.com/mattermost/mattermost/server/v8 Go | All versions | 8.0.0-20250612074655-8f8612c63783 |
github.com/mattermost/mattermost/server/v8 Go | All versions | 8.0.0-20250612074655-8f8612c63783 |
github.com/mattermost/mattermost/server/v8 Go | All versions | 8.0.0-20250612074655-8f8612c63783 |
Products include Mattermost Mattermost Server.
How do I fix CVE-2025-6227?
Upgrade github.com/mattermost/mattermost-server to a fixed version for your release line: 10.5.8, 9.11.17, 9.11.17+incompatible or 10.5.8+incompatible.
Is CVE-2025-6227 being exploited?
There is no known exploitation of CVE-2025-6227 in the wild and no public exploit code.
Other vulnerabilities in Mattermost Mattermost Server
- CVE-2025-12419 Account takeover on OAuth/OpenID-enabled servers
- CVE-2025-12421 Account Takeover via Code Exchange Endpoint
- CVE-2025-4981 Path Traversal Leading to RCE by Any Authenticated Mattermost User
- CVE-2025-20051 Arbitrary file read via block duplication in Mattermost Boards
- CVE-2025-25279 Arbitrary file read in Mattermost Boards via import & export board archive
Sources
Also known as GHSA-4fwj-8595-wp25, GO-2025-3818.