# CVE-2025-62276: Liferay Portal and DXP use an incorrect cache-control header

> Local users can access downloaded files via browser cache due to incorrect cache-control headers in Liferay Portal and DXP.

- **Severity:** Medium 4.6 (`CVSS:4.0/AV:L/AC:L/AT:N/PR:N/UI:A/VC:L/VI:L/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Local or same network only
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 31 Oct 2025
- **Updated:** 3 Nov 2025
- **Also known as:** GHSA-6533-fhr2-f38h

## What is CVE-2025-62276?

CVE-2025-62276 is a medium-severity vulnerability in Liferay Digital Experience Platform, published on 31 Oct 2025. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.

### Official description

The Document Library and the Adaptive Media modules in Liferay Portal 7.4.0 through 7.4.3.111, and older unsupported versions, and Liferay DXP 2023.Q4.0 through 2023.Q4.10, 2023.Q3.1 through 2023.Q3.10, 7.4 GA through update 92, and older unsupported versions uses an incorrect cache-control header, which allows local users to obtain access to downloaded files via the browser's cache.

Weakness: CWE-525 (Use of Web Browser Cache Containing Sensitive Information)

## Which versions are affected by CVE-2025-62276?

4 open source packages ship an affected version, including com.liferay.portal:com.liferay.portal.impl and com.liferay:com.liferay.adaptive.media.web. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `com.liferay.portal:com.liferay.portal.impl` | Maven | All versions | 69.1.0 |
| `com.liferay.portal:com.liferay.portal.impl` | Maven | All versions | 69.1.0 |
| `com.liferay:com.liferay.adaptive.media.web` | Maven | All versions | 5.0.52 |
| `com.liferay:com.liferay.adaptive.media.web` | Maven | All versions | 5.0.52 |

Products: Liferay Digital Experience Platform, Liferay Liferay Portal.

## How do I fix CVE-2025-62276?

Upgrade com.liferay.portal:com.liferay.portal.impl to 69.1.0 or later.

## Is CVE-2025-62276 being exploited?

There is no known exploitation of CVE-2025-62276 in the wild and no public exploit code.

## Other vulnerabilities in Liferay Digital Experience Platform

- [CVE-2024-8980](https://insights.sbomify.com/CVE-2024-8980/): Liferay Portal and Liferay DXP Vulnerable to CSRF in the Script Console (critical 9.6)
- [CVE-2023-42496](https://insights.sbomify.com/CVE-2023-42496/): Liferay Portal and Liferay DXP vulnerable to reflected Cross-site Scripting (critical 9.6)
- [CVE-2023-42498](https://insights.sbomify.com/CVE-2023-42498/): Liferay Portal Language Override edit screen and Liferay DXP vulnerable to reflected Cross-site Scripting (critical 9.6)
- [CVE-2024-25147](https://insights.sbomify.com/CVE-2024-25147/): Liferay Portal and Liferay DXP vulnerable to Cross-site Scripting (critical 9.6)
- [CVE-2024-26269](https://insights.sbomify.com/CVE-2024-26269/): Liferay Portal Frontend JS module's portlet.js and Liferay DXP vulnerable to Cross-site Scripting (critical 9.6)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-62276 and fix it if it is affected.

What it is: CVE-2025-62276 is a medium-severity vulnerability in Liferay Digital Experience Platform, published on 31 Oct 2025. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2025-62276 in the wild and no public exploit code.

Affected packages and fixed versions:
- com.liferay.portal:com.liferay.portal.impl (Maven): affected all versions; fixed in 69.1.0
- com.liferay.portal:com.liferay.portal.impl (Maven): affected all versions; fixed in 69.1.0
- com.liferay:com.liferay.adaptive.media.web (Maven): affected all versions; fixed in 5.0.52
- com.liferay:com.liferay.adaptive.media.web (Maven): affected all versions; fixed in 5.0.52

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-62276/ (Markdown: https://insights.sbomify.com/CVE-2025-62276/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-62276
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-62276
- OSV: https://osv.dev/vulnerability/CVE-2025-62276

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-62276/
Summaries are generated and may contain mistakes; the official description above is the record.
