CVE-2025-6233 Arbitrary file read by system admin via path traversal
A system administrator can read arbitrary system files via path traversal in bulk import attachments, requiring an upgrade to secure the platform.
- Exploited in the wild
- Not known
- Login needed
- An administrator
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2025-6233?
CVE-2025-6233 is a medium-severity path traversal vulnerability in Mattermost Mattermost Server, published on 18 Jul 2025. An attacker needs administrator access to exploit it, with no action from the victim.
Official description
Mattermost versions 10.8.x <= 10.8.1, 10.7.x <= 10.7.3, 10.5.x <= 10.5.7, 9.11.x <= 9.11.16 fail to sanitize input paths of file attachments in the bulk import JSONL file, which allows a system admin to read arbitrary system files via path traversal.
Weakness: CWE-22
Which versions are affected by CVE-2025-6233?
14 open source packages ship an affected version, including github.com/mattermost/mattermost-server, github.com/mattermost/mattermost-server/v5 and github.com/mattermost/mattermost-server/v6. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
github.com/mattermost/mattermost-server Go | From 10.5.0 | 10.5.8 |
github.com/mattermost/mattermost-server Go | From 10.5.0 | 10.5.8 |
github.com/mattermost/mattermost-server Go | From 10.7.0 | 10.7.4 |
github.com/mattermost/mattermost-server Go | From 10.7.0 | 10.7.4 |
github.com/mattermost/mattermost-server Go | From 10.8.0 | 10.8.2 |
github.com/mattermost/mattermost-server Go | From 10.8.0 | 10.8.2 |
8 more packages
github.com/mattermost/mattermost-server Go | From 9.11.0 | 9.11.17 |
github.com/mattermost/mattermost-server Go | From 9.11.0 | 9.11.17 |
github.com/mattermost/mattermost-server Go | From 9.11.0+incompatible | 9.11.17+incompatible, 10.5.8+incompatible, 10.7.4+incompatible, 10.8.2+incompatible |
github.com/mattermost/mattermost-server/v5 Go | All versions | None |
github.com/mattermost/mattermost-server/v6 Go | All versions | None |
github.com/mattermost/mattermost/server/v8 Go | All versions | 8.0.0-20250529054450-d38c27f96fcf |
github.com/mattermost/mattermost/server/v8 Go | All versions | 8.0.0-20250529054450-d38c27f96fcf |
github.com/mattermost/mattermost/server/v8 Go | All versions | 8.0.0-20250529054450-d38c27f96fcf |
Products include Mattermost Mattermost Server.
How do I fix CVE-2025-6233?
Upgrade github.com/mattermost/mattermost-server to a fixed version for your release line: 10.5.8, 10.7.4, 10.8.2 or 9.11.17.
Upgrade, and resolve every user-supplied path against an allowed base folder before opening it. More about Path traversal.
Is CVE-2025-6233 being exploited?
There is no known exploitation of CVE-2025-6233 in the wild and no public exploit code.
Other vulnerabilities in Mattermost Mattermost Server
- CVE-2025-12419 Account takeover on OAuth/OpenID-enabled servers
- CVE-2025-12421 Account Takeover via Code Exchange Endpoint
- CVE-2025-4981 Path Traversal Leading to RCE by Any Authenticated Mattermost User
- CVE-2025-20051 Arbitrary file read via block duplication in Mattermost Boards
- CVE-2025-25279 Arbitrary file read in Mattermost Boards via import & export board archive
Sources
Also known as GHSA-wvw2-3jh4-4c39, GO-2025-3820.