# CVE-2025-62348: Salt junos module uses an unsafe YAML loader which may allow unintended code execution

> Attackers can execute arbitrary code via crafted YAML payloads in the Salt junos module, requiring immediate patching of the Salt automation framework.

- **Severity:** High 7.3 (`CVSS:4.0/AV:L/AC:L/AT:P/PR:L/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 30 Jan 2026
- **Updated:** 26 Feb 2026
- **Also known as:** GHSA-77w2-v593-vxvv, PYSEC-2026-1894, UBUNTU-CVE-2025-62348

## What is CVE-2025-62348?

CVE-2025-62348 is a high-severity code injection vulnerability in Salt, published on 30 Jan 2026. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

Salt's junos execution module contained an unsafe YAML decode/load usage. A specially crafted YAML payload processed by the junos module could lead to unintended code execution under the context of the Salt process.

Weakness: CWE-94 (Improper Control of Generation of Code)

## Which versions are affected by CVE-2025-62348?

3 open source packages ship an affected version, including salt.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `salt` | PyPI | All versions | 3006.17 |
| `salt` | PyPI | All versions | 3006.17 |
| `salt` | PyPI | All versions | 3006.17 |

## How do I fix CVE-2025-62348?

Upgrade salt to 3006.17 or later.

## Is CVE-2025-62348 being exploited?

There is no known exploitation of CVE-2025-62348 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-62348 and fix it if it is affected.

What it is: CVE-2025-62348 is a high-severity code injection vulnerability in Salt, published on 30 Jan 2026. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-62348 in the wild and no public exploit code.

Affected packages and fixed versions:
- salt (PyPI): affected all versions; fixed in 3006.17
- salt (PyPI): affected all versions; fixed in 3006.17
- salt (PyPI): affected all versions; fixed in 3006.17

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-62348/ (Markdown: https://insights.sbomify.com/CVE-2025-62348/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-62348
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-62348
- OSV: https://osv.dev/vulnerability/CVE-2025-62348

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-62348/
Summaries are generated and may contain mistakes; the official description above is the record.
