# CVE-2025-62363: yt-grabber-tui allows arbitrary code execution via configurable yt-dlp path

> Attackers with filesystem write access can replace the configured yt-dlp executable to achieve arbitrary code execution when the application runs.

- **Severity:** High 7.8 (`CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 13 Oct 2025
- **Updated:** 14 Oct 2025
- **Also known as:** GHSA-94c4-wh57-8p9c

## What is CVE-2025-62363?

CVE-2025-62363 is a high-severity command injection vulnerability in zheny-creator YtGrabber-TUI, published on 13 Oct 2025. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

yt-grabber-tui is a terminal user interface application for downloading videos. In versions before 1.0-rc, the application allows users to configure the path to the yt-dlp executable via the path_to_yt_dlp configuration setting. An attacker with write access to the configuration file or the filesystem location of the configured executable can replace the executable with malicious code or create a symlink to an arbitrary executable. When the application invokes yt-dlp, the malicious code is executed with the privileges of the user running yt-grabber-tui. This vulnerability has been patched in version 1.0-rc.

Weakness: CWE-59 (Improper Link Resolution Before File Access)

## Which versions are affected by CVE-2025-62363?


## How do I fix CVE-2025-62363?

No fix has been published for CVE-2025-62363 yet. Limit exposure of the affected software until one is available.

## Is CVE-2025-62363 being exploited?

There is no known exploitation of CVE-2025-62363 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-62363 and fix it if it is affected.

What it is: CVE-2025-62363 is a high-severity command injection vulnerability in zheny-creator YtGrabber-TUI, published on 13 Oct 2025. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-62363 in the wild and no public exploit code.

Affected product: zheny-creator YtGrabber-TUI. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-62363/ (Markdown: https://insights.sbomify.com/CVE-2025-62363/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-62363
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-62363
- OSV: https://osv.dev/vulnerability/CVE-2025-62363

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-62363/
Summaries are generated and may contain mistakes; the official description above is the record.
