# CVE-2025-62364: text-generation-webui allows arbitrary file read via symbolic link upload

> An unauthenticated attacker can read arbitrary server files by uploading a symbolic link, exposing sensitive data like credentials and configurations.

- **Severity:** Medium 6.2 (`CVSS:3.1/AV:L/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 13 Oct 2025
- **Updated:** 14 Oct 2025
- **Also known as:** GHSA-66rw-q8w5-c2hg

## What is CVE-2025-62364?

CVE-2025-62364 is a medium-severity path traversal vulnerability in oobabooga text-generation-webui, published on 13 Oct 2025. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

text-generation-webui is an open-source web interface for running Large Language Models. In versions through 3.13, a Local File Inclusion vulnerability exists in the character picture upload feature. An attacker can upload a text file containing a symbolic link to an arbitrary file path. When the application processes the upload, it follows the symbolic link and serves the contents of the targeted file through the web interface. This allows an unauthenticated attacker to read sensitive files on the server, potentially exposing system configurations, credentials, and other confidential information. This vulnerability is fixed in 3.14. No known workarounds exist.

Weakness: CWE-59 (Improper Link Resolution Before File Access)

## Which versions are affected by CVE-2025-62364?


## How do I fix CVE-2025-62364?

No fix has been published for CVE-2025-62364 yet. Limit exposure of the affected software until one is available.

## Is CVE-2025-62364 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-62364 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-62364 and fix it if it is affected.

What it is: CVE-2025-62364 is a medium-severity path traversal vulnerability in oobabooga text-generation-webui, published on 13 Oct 2025. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-62364 exists.

Affected product: oobabooga text-generation-webui. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-62364/ (Markdown: https://insights.sbomify.com/CVE-2025-62364/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-62364
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-62364
- OSV: https://osv.dev/vulnerability/CVE-2025-62364

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-62364/
Summaries are generated and may contain mistakes; the official description above is the record.
