# CVE-2025-62365: LibreNMS vulnerable to Reflected-XSS in `report_this` function

> Attackers can execute arbitrary scripts in victim browsers via reflected XSS in LibreNMS, potentially leading to session hijacking or data theft.

- **Severity:** Medium 5.5 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:N/SC:L/SI:L/SA:N/E:P`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 13 Oct 2025
- **Updated:** 14 Oct 2025
- **Also known as:** GHSA-86rg-8hc8-v82p

## What is CVE-2025-62365?

CVE-2025-62365 is a medium-severity cross-site scripting vulnerability in Librenms Librenms, published on 13 Oct 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

LibreNMS is an open-source, PHP/MySQL/SNMP-based network monitoring system. Prior to 25.7.0, there is a reflected-XSS in `report_this` function in `librenms/includes/functions.php`. The `report_this` function had improper filtering (`htmlentities` function was incorrectly use in a href environment), which caused the `project_issues` parameter to trigger an XSS vulnerability. This vulnerability is fixed in 25.7.0.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2025-62365?

2 open source packages ship an affected version, including librenms/librenms. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `librenms/librenms` | Packagist | All versions | 25.7.0 |
| `librenms/librenms` | Packagist | All versions | 25.7.0 |

Products: Librenms Librenms.

## How do I fix CVE-2025-62365?

Upgrade librenms/librenms to 25.7.0 or later.

## Is CVE-2025-62365 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-62365 exists.

## Other vulnerabilities in Librenms Librenms

- [CVE-2023-4982](https://insights.sbomify.com/CVE-2023-4982/): Cross-site Scripting (XSS) - Stored in librenms/librenms (critical 9.8)
- [CVE-2022-29712](https://insights.sbomify.com/CVE-2022-29712/): Command injection in librenms (critical 9.8)
- [CVE-2021-44278](https://insights.sbomify.com/CVE-2021-44278/): Path traversal in librenms/librenms (critical 9.8)
- [CVE-2019-10665](https://insights.sbomify.com/CVE-2019-10665/): LibreNMS Information Disclosure (critical 9.8)
- [CVE-2018-20434](https://insights.sbomify.com/CVE-2018-20434/): LibreNMS arbitrary OS commands execution (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-62365 and fix it if it is affected.

What it is: CVE-2025-62365 is a medium-severity cross-site scripting vulnerability in Librenms Librenms, published on 13 Oct 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-62365 exists.

Affected packages and fixed versions:
- librenms/librenms (Packagist): affected all versions; fixed in 25.7.0
- librenms/librenms (Packagist): affected all versions; fixed in 25.7.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-62365/ (Markdown: https://insights.sbomify.com/CVE-2025-62365/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-62365
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-62365
- OSV: https://osv.dev/vulnerability/CVE-2025-62365

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-62365/
Summaries are generated and may contain mistakes; the official description above is the record.
