# CVE-2025-62366: Mailgen vulnerable to HTML injection and cross-site scripting via plaintext email generation

> Attacker can execute JavaScript via HTML injection in plaintext emails if rendered as HTML, affecting users of the mailgen Node.js library.

- **Severity:** Low 2.9 (`CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:N/VI:N/VA:N/SC:L/SI:L/SA:N/E:P`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 14 Oct 2025
- **Updated:** 14 Oct 2025
- **Also known as:** GHSA-xw6r-chmh-vpmj

## What is CVE-2025-62366?

CVE-2025-62366 is a low-severity cross-site scripting vulnerability in eladnava mailgen, published on 14 Oct 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

mailgen is a Node.js package that generates responsive HTML e-mails for sending transactional mail. Mailgen versions through 2.0.30 contain an HTML injection vulnerability in plaintext emails produced by the generatePlaintext method when user‑generated content is supplied. The function attempts to remove HTML tags, but if tags are provided as encoded HTML entities they are not removed and are later decoded, resulting in active HTML (for example an img tag with an event handler) in the supposed plaintext output. In contexts where the generated plaintext string is subsequently rendered as HTML, this can allow execution of attacker‑controlled JavaScript. Versions 2.0.31 and later contain a fix. No known workarounds exist.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2025-62366?

2 open source packages ship an affected version, including mailgen.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `mailgen` | npm | All versions | 2.0.31 |
| `mailgen` | npm | All versions | 2.0.31 |

## How do I fix CVE-2025-62366?

Upgrade mailgen to 2.0.31 or later.

## Is CVE-2025-62366 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-62366 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-62366 and fix it if it is affected.

What it is: CVE-2025-62366 is a low-severity cross-site scripting vulnerability in eladnava mailgen, published on 14 Oct 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-62366 exists.

Affected packages and fixed versions:
- mailgen (npm): affected all versions; fixed in 2.0.31
- mailgen (npm): affected all versions; fixed in 2.0.31

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-62366/ (Markdown: https://insights.sbomify.com/CVE-2025-62366/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-62366
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-62366
- OSV: https://osv.dev/vulnerability/CVE-2025-62366

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-62366/
Summaries are generated and may contain mistakes; the official description above is the record.
