CVE-2025-62368 Taiga Authenticated Remote Code Execution

Critical 9.1 Published Updated

An authenticated attacker can execute arbitrary code on the Taiga project management platform via unsafe deserialization in the API.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
None listed

What is CVE-2025-62368?

CVE-2025-62368 is a critical unsafe deserialization vulnerability in taigaio taiga-back, published on 28 Oct 2025. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

Official description

Taiga is an open source project management platform. In versions 6.8.3 and earlier, a remote code execution vulnerability exists in the Taiga API due to unsafe deserialization of untrusted data. This issue is fixed in version 6.9.0.

Weakness: CWE-502

Which versions are affected by CVE-2025-62368?

How do I fix CVE-2025-62368?

No fix has been published for CVE-2025-62368 yet. Limit exposure of the affected software until one is available.

Upgrade, and only deserialise data from trusted sources or with an allow-list of types. More about Unsafe deserialization.

Is CVE-2025-62368 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-62368 exists.

Public exploit code: 1 Metasploit module.

Sources

Also known as GHSA-cpcf-9276-fwc5.

Is CVE-2025-62368 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free