# CVE-2025-62368: Taiga Authenticated Remote Code Execution

> An authenticated attacker can execute arbitrary code on the Taiga project management platform via unsafe deserialization in the API.

- **Severity:** Critical 9.1 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** No
- **Published:** 28 Oct 2025
- **Updated:** 29 Oct 2025
- **Also known as:** GHSA-cpcf-9276-fwc5

## What is CVE-2025-62368?

CVE-2025-62368 is a critical unsafe deserialization vulnerability in taigaio taiga-back, published on 28 Oct 2025. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

Taiga is an open source project management platform. In versions 6.8.3 and earlier, a remote code execution vulnerability exists in the Taiga API due to unsafe deserialization of untrusted data. This issue is fixed in version 6.9.0.

Weakness: CWE-502 (Deserialization of Untrusted Data)

## Which versions are affected by CVE-2025-62368?


## How do I fix CVE-2025-62368?

No fix has been published for CVE-2025-62368 yet. Limit exposure of the affected software until one is available.

## Is CVE-2025-62368 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-62368 exists.

Public exploit code:

- Taiga tribe_gig authenticated unserialize remote code execution (metasploit)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-62368 and fix it if it is affected.

What it is: CVE-2025-62368 is a critical unsafe deserialization vulnerability in taigaio taiga-back, published on 28 Oct 2025. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-62368 exists.

Affected product: taigaio taiga-back. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-62368/ (Markdown: https://insights.sbomify.com/CVE-2025-62368/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-62368
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-62368
- OSV: https://osv.dev/vulnerability/CVE-2025-62368

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-62368/
Summaries are generated and may contain mistakes; the official description above is the record.
