{"answers":{"affected":"3 open source packages ship an affected version, including invokeai.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-6237 exists.","fix":"Upgrade invokeai to 6.7.0 or later.","what":"CVE-2025-6237 is a critical path traversal vulnerability in invoke-ai/invokeai, published on 18 Sep 2025. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2025-6237 and fix it if it is affected.\n\nWhat it is: CVE-2025-6237 is a critical path traversal vulnerability in invoke-ai/invokeai, published on 18 Sep 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-6237 exists.\n\nAffected packages and fixed versions:\n- invokeai (PyPI): affected all versions; fixed in 6.7.0\n- invokeai (PyPI): affected all versions; fixed in 6.7.0\n- invokeai (PyPI): affected all versions; fixed in 6.7.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-6237/ (Markdown: https://insights.sbomify.com/CVE-2025-6237/index.md)","id":"CVE-2025-6237","markdown":"https://insights.sbomify.com/CVE-2025-6237/index.md","name":"CVE-2025-6237","record":{"aliases":["GHSA-vv9c-xxg7-wmv7","PYSEC-2026-359"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["data_read","data_modify"],"network_reachable":"yes","non_default_config":false,"product_category":"AI image generation app","requires_auth":"none","summary":"Attackers can exploit path traversal to read and delete arbitrary files on the server via a vulnerable API endpoint.","user_interaction":"not_required","vuln_class":"path_traversal"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"@huntr_ai","cpe":[],"cvss":{"score":9.8,"severity":"critical","source":"cna","vector":"CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H","version":"3.0"},"cwes":[{"id":"CWE-73","name":"External Control of File Name or Path"}],"description":"A vulnerability in invokeai version v6.0.0a1 and below allows attackers to perform path traversal and arbitrary file deletion via the GET /api/v1/images/download/{bulk_download_item_name} endpoint. By manipulating the filename arguments, attackers can read and delete any files on the server, including critical system files such as SSH keys, databases, and configuration files. This vulnerability results in high confidentiality, integrity, and availability impacts.","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"Path Traversal and Arbitrary File Deletion in invoke-ai/invokeai","id":"CVE-2025-6237","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"path_traversal","year":"2025"},"n_packages":3,"n_references":1,"next":{"headline":"AI Engine 2.8.4 - Insecure OAuth Implementation","id":"CVE-2025-6238"},"packages":[{"ecosystem":"PyPI","fixed":["6.7.0"],"introduced":["0"],"last_affected":[],"package":"invokeai","purl":null,"source":"GHSA-vv9c-xxg7-wmv7"},{"ecosystem":"PyPI","fixed":["6.7.0"],"introduced":["0"],"last_affected":[],"package":"invokeai","purl":"pkg:pypi/invokeai","source":"GHSA-vv9c-xxg7-wmv7"},{"ecosystem":"PyPI","fixed":["6.7.0"],"introduced":["0"],"last_affected":[],"package":"invokeai","purl":"pkg:pypi/invokeai","source":"PYSEC-2026-359"}],"prev":{"headline":"Hostel \u003c 1.1.5.9 - Admin+ Stored XSS","id":"CVE-2025-6236"},"products":["invoke-ai/invokeai"],"published":"2025-09-18","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"poc","technical_impact":"total"},"state":"PUBLISHED","updated":"2025-09-18","vendors":["invoke-ai"]},"summary":"Attackers can exploit path traversal to read and delete arbitrary files on the server via a vulnerable API endpoint.","url":"https://insights.sbomify.com/CVE-2025-6237/"}