CVE-2025-62370 Alloy Core has a DoS vulnerability on `alloy_dyn_abi::TypedData` hashing
Malformed input to TypedData hashing causes an uncaught panic, leading to denial of service in applications using the Alloy Core library.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2025-62370?
CVE-2025-62370 is a high-severity denial of service vulnerability in alloy-rs core, published on 15 Oct 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
Alloy Core libraries at the root of the Rust Ethereum ecosystem. Prior to 0.8.26 and 1.4.1, an uncaught panic triggered by malformed input to alloy_dyn_abi::TypedData could lead to a denial-of-service (DoS) via eip712_signing_hash(). Software with high availability requirements such as network services may be particularly impacted. If in use, external auto-restarting mechanisms can partially mitigate the availability issues unless repeated attacks are possible. The vulnerability was patched by adding a check to ensure the element is not empty before accessing its first element; an error is returned if it is empty. The fix is included in version v1.4.1 and backported to v0.8.26.
Weakness: CWE-248
Which versions are affected by CVE-2025-62370?
5 open source packages ship an affected version, including alloy-dyn-abi.
| Package | Affected | Fixed in |
|---|---|---|
alloy-dyn-abi crates.io | All versions | 0.8.26 |
alloy-dyn-abi crates.io | All versions | 0.8.26 |
alloy-dyn-abi crates.io | From 0.0.0-0 | 0.8.26, 1.4.1 |
alloy-dyn-abi crates.io | From 1.0.0 | 1.4.1 |
alloy-dyn-abi crates.io | From 1.0.0 | 1.4.1 |
Linux distribution packages (1)
cargo-audit-advisory-db openSUSE:Tumbleweed | All versions | 20251021-1.1 |
How do I fix CVE-2025-62370?
Upgrade alloy-dyn-abi to a fixed version for your release line: 0.8.26 or 1.4.1.
Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.
Is CVE-2025-62370 being exploited?
There is no known exploitation of CVE-2025-62370 in the wild and no public exploit code.
Sources
Also known as GHSA-pgp9-98jm-wwq2, RUSTSEC-2025-0073, openSUSE-SU-2025:15652-1.