# CVE-2025-62370: Alloy Core has a DoS vulnerability on `alloy_dyn_abi::TypedData` hashing

> Malformed input to TypedData hashing causes an uncaught panic, leading to denial of service in applications using the Alloy Core library.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 15 Oct 2025
- **Updated:** 15 Oct 2025
- **Also known as:** GHSA-pgp9-98jm-wwq2, RUSTSEC-2025-0073, openSUSE-SU-2025:15652-1

## What is CVE-2025-62370?

CVE-2025-62370 is a high-severity denial of service vulnerability in alloy-rs core, published on 15 Oct 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Alloy Core libraries at the root of the Rust Ethereum ecosystem. Prior to 0.8.26 and 1.4.1, an uncaught panic triggered by malformed input to alloy_dyn_abi::TypedData could lead to a denial-of-service (DoS) via eip712_signing_hash(). Software with high availability requirements such as network services may be particularly impacted. If in use, external auto-restarting mechanisms can partially mitigate the availability issues unless repeated attacks are possible. The vulnerability was patched by adding a check to ensure the element is not empty before accessing its first element; an error is returned if it is empty. The fix is included in version v1.4.1 and backported to v0.8.26.

Weakness: CWE-248 (Uncaught Exception)

## Which versions are affected by CVE-2025-62370?

5 open source packages ship an affected version, including alloy-dyn-abi.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `alloy-dyn-abi` | crates.io | All versions | 0.8.26 |
| `alloy-dyn-abi` | crates.io | All versions | 0.8.26 |
| `alloy-dyn-abi` | crates.io | From 0.0.0-0 | 0.8.26, 1.4.1 |
| `alloy-dyn-abi` | crates.io | From 1.0.0 | 1.4.1 |
| `alloy-dyn-abi` | crates.io | From 1.0.0 | 1.4.1 |
| `cargo-audit-advisory-db` | openSUSE:Tumbleweed | All versions | 20251021-1.1 |

## How do I fix CVE-2025-62370?

Upgrade alloy-dyn-abi to a fixed version for your release line: 0.8.26 or 1.4.1.

## Is CVE-2025-62370 being exploited?

There is no known exploitation of CVE-2025-62370 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-62370 and fix it if it is affected.

What it is: CVE-2025-62370 is a high-severity denial of service vulnerability in alloy-rs core, published on 15 Oct 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-62370 in the wild and no public exploit code.

Affected packages and fixed versions:
- alloy-dyn-abi (crates.io): affected all versions; fixed in 0.8.26
- alloy-dyn-abi (crates.io): affected all versions; fixed in 0.8.26
- alloy-dyn-abi (crates.io): affected from 0.0.0-0; fixed in 0.8.26, 1.4.1
- alloy-dyn-abi (crates.io): affected from 1.0.0; fixed in 1.4.1
- alloy-dyn-abi (crates.io): affected from 1.0.0; fixed in 1.4.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-62370/ (Markdown: https://insights.sbomify.com/CVE-2025-62370/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-62370
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-62370
- OSV: https://osv.dev/vulnerability/CVE-2025-62370

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-62370/
Summaries are generated and may contain mistakes; the official description above is the record.
