{"answers":{"affected":"2 open source packages ship an affected version, including org.opensearch.dataprepper.plugins:opensearch. It affects 1 product.","exploited":"There is no known exploitation of CVE-2025-62371 in the wild and no public exploit code.","fix":"Upgrade org.opensearch.dataprepper.plugins:opensearch to 2.12.2 or later.","what":"CVE-2025-62371 is a high-severity vulnerability in opensearch-project data-prepper, published on 15 Oct 2025. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2025-62371 and fix it if it is affected.\n\nWhat it is: CVE-2025-62371 is a high-severity vulnerability in opensearch-project data-prepper, published on 15 Oct 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2025-62371 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- org.opensearch.dataprepper.plugins:opensearch (Maven): affected all versions; fixed in 2.12.2\n- org.opensearch.dataprepper.plugins:opensearch (Maven): affected all versions; fixed in 2.12.2\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-62371/ (Markdown: https://insights.sbomify.com/CVE-2025-62371/index.md)","id":"CVE-2025-62371","markdown":"https://insights.sbomify.com/CVE-2025-62371/index.md","name":"CVE-2025-62371","record":{"aliases":["GHSA-43ff-rr26-8hx4"],"analysis":{"component_type":"server_software","fix_type":"upgrade","impacts":["data_read","data_modify"],"network_reachable":"yes","non_default_config":false,"product_category":"OpenSearch Data Prepper","requires_auth":"none","summary":"OpenSearch Data Prepper plugins bypass SSL validation by default, allowing man-in-the-middle attacks to intercept or modify data in transit.","user_interaction":"not_required","vuln_class":"security_feature_bypass"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"opensearch_data_prepper","vendor":"amazon"}],"cvss":{"score":7.4,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:N","version":"3.1"},"cwes":[{"id":"CWE-295","name":"Improper Certificate Validation"}],"description":"OpenSearch Data Prepper as an open source data collector for observability data. In versions prior to 2.12.2, the OpenSearch sink and source plugins in Data Prepper trust all SSL certificates by default when no certificate path is provided. Prior to this fix, the OpenSearch sink and source plugins would automatically use a trust all SSL strategy when connecting to OpenSearch clusters if no certificate path was explicitly configured. This behavior bypasses SSL certificate validation, potentially allowing attackers to intercept and modify data in transit through man-in-the-middle attacks. The vulnerability affects connections to OpenSearch when the cert parameter is not explicitly provided. This issue has been patched in version 2.12.2. As a workaround, users can add the cert parameter to their OpenSearch sink or source configuration with the path to the cluster's CA certificate.","ecosystems":["Maven"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"OpenSearch Data Prepper plugins trusts all SSL certificates by default","id":"CVE-2025-62371","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Maven","product":null,"products":[],"type":"security_feature_bypass","year":"2025"},"n_packages":2,"n_references":4,"next":{"headline":"vLLM vulnerable to DoS with incorrect shape of multimodal embedding inputs","id":"CVE-2025-62372"},"packages":[{"ecosystem":"Maven","fixed":["2.12.2"],"introduced":["0"],"last_affected":[],"package":"org.opensearch.dataprepper.plugins:opensearch","purl":null,"source":"GHSA-43ff-rr26-8hx4"},{"ecosystem":"Maven","fixed":["2.12.2"],"introduced":["0"],"last_affected":[],"package":"org.opensearch.dataprepper.plugins:opensearch","purl":"pkg:maven/org.opensearch.dataprepper.plugins/opensearch","source":"GHSA-43ff-rr26-8hx4"}],"prev":{"headline":"Alloy Core has a DoS vulnerability on `alloy_dyn_abi::TypedData` hashing","id":"CVE-2025-62370"},"products":["data-prepper"],"published":"2025-10-15","related":[{"cvss_score":6.9,"headline":"OpenTelemetry Logs source may lack authentication with some custom plugins","id":"CVE-2024-55886","kev_date_added":null,"published":"2024-12-12"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-10-15","vendors":["opensearch-project"]},"summary":"OpenSearch Data Prepper plugins bypass SSL validation by default, allowing man-in-the-middle attacks to intercept or modify data in transit.","url":"https://insights.sbomify.com/CVE-2025-62371/"}