# CVE-2025-62371: OpenSearch Data Prepper plugins trusts all SSL certificates by default

> OpenSearch Data Prepper plugins bypass SSL validation by default, allowing man-in-the-middle attacks to intercept or modify data in transit.

- **Severity:** High 7.4 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 15 Oct 2025
- **Updated:** 15 Oct 2025
- **Also known as:** GHSA-43ff-rr26-8hx4

## What is CVE-2025-62371?

CVE-2025-62371 is a high-severity vulnerability in opensearch-project data-prepper, published on 15 Oct 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

OpenSearch Data Prepper as an open source data collector for observability data. In versions prior to 2.12.2, the OpenSearch sink and source plugins in Data Prepper trust all SSL certificates by default when no certificate path is provided. Prior to this fix, the OpenSearch sink and source plugins would automatically use a trust all SSL strategy when connecting to OpenSearch clusters if no certificate path was explicitly configured. This behavior bypasses SSL certificate validation, potentially allowing attackers to intercept and modify data in transit through man-in-the-middle attacks. The vulnerability affects connections to OpenSearch when the cert parameter is not explicitly provided. This issue has been patched in version 2.12.2. As a workaround, users can add the cert parameter to their OpenSearch sink or source configuration with the path to the cluster's CA certificate.

Weakness: CWE-295 (Improper Certificate Validation)

## Which versions are affected by CVE-2025-62371?

2 open source packages ship an affected version, including org.opensearch.dataprepper.plugins:opensearch. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.opensearch.dataprepper.plugins:opensearch` | Maven | All versions | 2.12.2 |
| `org.opensearch.dataprepper.plugins:opensearch` | Maven | All versions | 2.12.2 |

Products: Amazon Opensearch Data Prepper.

## How do I fix CVE-2025-62371?

Upgrade org.opensearch.dataprepper.plugins:opensearch to 2.12.2 or later.

## Is CVE-2025-62371 being exploited?

There is no known exploitation of CVE-2025-62371 in the wild and no public exploit code.

## Other vulnerabilities in opensearch-project data-prepper

- [CVE-2024-55886](https://insights.sbomify.com/CVE-2024-55886/): OpenTelemetry Logs source may lack authentication with some custom plugins (medium 6.9)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-62371 and fix it if it is affected.

What it is: CVE-2025-62371 is a high-severity vulnerability in opensearch-project data-prepper, published on 15 Oct 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-62371 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.opensearch.dataprepper.plugins:opensearch (Maven): affected all versions; fixed in 2.12.2
- org.opensearch.dataprepper.plugins:opensearch (Maven): affected all versions; fixed in 2.12.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-62371/ (Markdown: https://insights.sbomify.com/CVE-2025-62371/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-62371
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-62371
- OSV: https://osv.dev/vulnerability/CVE-2025-62371

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-62371/
Summaries are generated and may contain mistakes; the official description above is the record.
